or Connect
Head-Fi.org › Forums › Equipment Forums › Computer Audio › X-fi Go! Pro buzzing noise
New Posts  All Forums:Forum Nav:

X-fi Go! Pro buzzing noise - Page 3

post #31 of 34

I just purchased one to do a side by side comparison to my asus u3. I hope I do not get the hissing problem. 

post #32 of 34

Hi! I have this problem too. You can hear very clear in Hanz Zimmer "Time" and others kind of musics like this. I found this http://incentives-matter.blogspot.com.br/2012/03/solution-to-sound-blaster-x-fi-go-pro.html . But I didn't understand how to make.

post #33 of 34

I have never understood why Creative is still in business!:confused_face_2: 

 

especially considering nice brands like EMU or Auzentech, have been long dead..


Edited by sonci - 7/10/15 at 1:06pm
post #34 of 34

I have the SB X-Fi pro and i get a high end buzzing noise, right at the top end. Now this was getting on my nerves as it ruins music sound and no matter what driver I used or what I turned on and off it was always there. Threw it in my IT pile thinking I would sit on it and try something else later. 

Today I dug out my D-Link powered hub and plugged this into my pc and fed the SB off of this, high pitch noise gone. The hub must be filtering out some noise interference or something. Any way thought I would share but getting a ASUS card next time.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › X-fi Go! Pro buzzing noise