or Connect
Head-Fi.org › Forums › Misc.-Category Forums › DIY (Do-It-Yourself) Discussions › eXStatA Build Thread II
New Posts  All Forums:Forum Nav:

eXStatA Build Thread II - Page 40

post #586 of 587

Waking the thread from the dead ...


My exstata gave me a shock some days ago!


I was listening to some music (moderate levels) with my Lambda Pro when

suddenly the sound started distorting on the left channel and I got some

deep hum too.


Unplugged the phones of course and tested them on my srm xh where

they worked properly - so the extata seems to be the problem.


I ran through the setup again today and checked all the voltages and

found nothing too alarming. Offset was about 5V on one channel, what

does not seem to be critical (adjusted back to below 1V nonetheless).


Now I'm kind of scared to plug in my phones again since I don't have

any clue where the problem might have been.



Any Idea?

post #587 of 587
Thanks for reviving this thread. I'm an owner of an Exstata that I bought from Mjolnir Audio last year which is solid state and has an upgraded power supply. I've never been able to find out much info about it, and bought it as an upgrade for my stock Koss ESP energizer.

i was wondering how this model compares to the stock Stax amps and some of the Kevin Gilmore designs, as I'm probably going to buy L700s at some point and want to get an idea of what kind of improvement I might get with something like a KGST, etc.

Sorry to threadjack Sathimas. i'm hoping enough people see this thread again to answer both our questions.
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Misc.-Category Forums › DIY (Do-It-Yourself) Discussions › eXStatA Build Thread II