Head-Fi.org › Forums › Equipment Forums › Computer Audio › Changing op-amps on Creative X-fi titanium HD
New Posts  All Forums:Forum Nav:

Changing op-amps on Creative X-fi titanium HD - Page 2

post #16 of 19

http://translate.google.com/translate?u=http%3A%2F%2Fcode.google.com%2Fp%2Fbitspersampleconv2%2Fwiki%2FSoundBlasterTiHdOpampComparison&sl=ja&tl=en


Edited by Alexander01 - 6/18/10 at 10:59am
post #17 of 19

Im actually on the same boat, now that the HD is for sale in USA I just installed mine upgrading from the normal Xfi Titanium.  It sounds pretty similar, although its slightly lacking bass I think.  Has anyone played with the op amps in these?

post #18 of 19
fyi, here's creative's page about replacing op-amps
Quote:
Originally Posted by http://support.creative.com/kb/ShowArticle.aspx?sid=85621 

- 8-pin
- Single or dual DIP (Dual- In-Line package)
- Voltage Range +/- 5V to +/- 15V
post #19 of 19

Replaced the OpAmps with cans, used OPA2111 for the duals, and can versions of the same LME 4971's, both as recommended on the guru3d review.  Sounds great.  Had to use some .25" spacers and 1cm long M3 metric screws to put the cover back on because they protrude too far from the PCB. 

 

Mouser had both OpAmps if you are interested.  Used the Brown Dog adapters, very difficult to solder and cut leads but worth the effort.

 

picts:  http://m34t.net/OpAmpCans

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Changing op-amps on Creative X-fi titanium HD