Head-Fi.org › Forums › Equipment Forums › Computer Audio › DTS Playback
New Posts  All Forums:Forum Nav:

DTS Playback

post #1 of 8
Thread Starter 

Can someone PLEASE help me troubleshoot the following?

DTS Playback from PC through optical/spdif/toslink cable to Receiver.


Win7 Ultimate 32bit

Motherboard        Asus m4a785td-m evo

Audio chip        VT1708S 8-Channel High Definition Audio CODEC

Receiver/Speakers    Logitech Z-5500

Now the bizarre part 1
When I go to the properties of my HD Audio device, and I do the tests there, the DD and DTS
works fine as well as all the sample rates including 44.1.
If I play the DD test my receiver shows DD
If I play the DTS test my receiver shows DTS
So i am PRETTY sure my equipment (Hardware) is capable of everything.
(By the way, where does Windows store those test samples? what is the bits and rates?)

Now the bizarre part 2
If I play my movie through XBMC I get the DD stream on my receiver.
If I play my movie through normal players (WMP or VLC), the stream is mixed down.

Now the bizarre part 3
None of my Kelly industries samples want to play in DTS, the stream is mixed down.

Why do my Windows test files work and shows the correct stream???
But through the normal players it doesn't work??
Can anyone recommend different programs instead of VLC (which I think is kick-ass)?


post #2 of 8

Make sure the sample rate is not set to 44.1 for AC3 and DTS.  It should be 48kHz. 


VLC is crap for multichannel surround sound.  It does not work.


Try Media Player Classic Home Cinema.  You'll need to also use AC3Filter and make sure to change the settings under "SPDIF" tab to having SPDIF passthrough, check off both AC3 and DTS.  Then for SPDIF/DTS mode, make sure it's set to "Auto" and not, SPDIF wrapped.  Under "SPDIF options" uncheck "Use AC3 encoder". 


Important settings under MPC Home Cinemas:


Right click, goto "Options".  Goto "Internal Filters".   Make sure "AC3" and "DTS" are NOT checked.  Hit "Apply" and OK.


Then fire up a movie and see if your DTS is lighting up on your receiver.

This setup is fairly simple, and DTS-ES M and DTS-ES D get passed through properly as well. 


KMPlayer also works, but DVXA acceleration plain sucks with it with the latest graphics chips.



Edited by Edwood - 5/22/10 at 4:15am
post #3 of 8
Thread Starter 

OMW, thanks for the VERY quick reply, at work at the moment (not very productive :))

Will give feedback when I get home.


Keep well!!

post #4 of 8
Thread Starter 

Hi Edwood


Still no luck, will keep on trying and see if i can figure is out.


If not I will ask help again.


All the sample clips I have is in 44.1, might that be the issue? where do i get that "test file" that works when i test the DTS and DD through windows? Might that sample be 48 instead of 44.1?


Thanks again

post #5 of 8
Thread Starter 



Tested a crapload of different files tonight.


Everything works on either VLC or MPC HC or on both... Except for 3 files.


They all appear to be


44.1 KHz DTS .WAV files.


Should my system play them? or are they just unplayable?



post #6 of 8

For the 44.1khz files you have to set your soundcard's digital output to 44.1khz (else they will be resampled to 48khz and cannot be decoded properly anymore).

post #7 of 8
Thread Starter 

Cool, gonna check that out at home, maybe I just missed that after changing sooo many settings in the player interfaces. 

Will give feedback.


post #8 of 8
Thread Starter 

Very interesting thing here, on my Settings tab, I can change my HDMI ouput to 44.1 but the SPDIF only to 48 and 96, I think someone may BS'ed by telling me all formats will be supported.


Thank You for all the help.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › DTS Playback