Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Matrix M-Stage amp review: simple, cheap, and excellent.
New Posts  All Forums:Forum Nav:

Matrix M-Stage amp review: simple, cheap, and excellent. - Page 237

post #3541 of 4830
Quote:
Originally Posted by chicolom View Post

lol

We try to climax (musically) at the same time.

We need to hook you up with Selena Gomez.........wink.gif
post #3542 of 4830

What do you think about Matrix M-Stage + DT880 Edition 600 Ohms. Would Matrix provide sufficient voltage to these high impendance cans? Any experiences? Thanks.

post #3543 of 4830
Quote:
Originally Posted by muxamed View Post

What do you think about Matrix M-Stage + DT880 Edition 600 Ohms. Would Matrix provide sufficient voltage to these high impendance cans? Any experiences? Thanks.


Without a doubt, it powered my DT990 600ohm really well.

post #3544 of 4830

On another note, I had a terrible misfortune today.

 

When I turned on my M-Stage, volume always set at 0% (10db) if I'm not listening, I left the room for 4 minutes. When I returned my entire room smelled like burnt plastic. I instantly powered off my DAC and amp and unplugged them both, taking each device out into different rooms. The M-Stage was definately the culprit as it gave away the horrible odour. Hopefully I managed to stop any fire since I didnt see any smoke rising. The M-Stage was not very hot to touch, it's been hotter before during 3h+ long playing sessions. But this time it did take a while for it to cool off.

 

Contacted coolfungaget about this. Hopefully it didnt do any damage to my HD650s that were connected to the amp. But let us only hope.

post #3545 of 4830

Jeez, after two instances of this now, I'm worried.

post #3546 of 4830
Quote:
Originally Posted by Taowolf51 View Post

Jeez, after two instances of this now, I'm worried.


Hm, who's the other unfortunate headfier(s)?

post #3547 of 4830
Quote:
Originally Posted by Taowolf51 View Post

Jeez, after two instances of this now, I'm worried.
This is so weird..never heared of any problems with mstages...is the quality control on the new batches worse..or ...am afraid to say it..but..its funny this happens to products not bought directly at tamaudio..i had the first series..and never ever heard any problems with that version..only maybe the gain switches being switched.. biggrin.gif so get urself a first version last series of that was sold beginning of 2012 i think..or buy at tamaudio. I am also so shocked of these occuring problems with the normallly solid mstage.
post #3548 of 4830
Quote:
Originally Posted by hifimanrookie View Post


This is so weird..never heared of any problems with mstages...is the quality control on the new batches worse..or ...am afraid to say it..but..its funny this happens to products not bought directly at tamaudio..i had the first series..and never ever heard any problems with that version..only maybe the gain switches being switched.. biggrin.gif so get urself a first version last series of that was sold beginning of 2012 i think..or buy at tamaudio. I am also so shocked of these occuring problems with the normallly solid mstage.


coolfungadget is tamaudio.

post #3549 of 4830
Quote:
Originally Posted by Monir View Post


coolfungadget is tamaudio.
Oh ok..didnt know that.. Then the quality control is not working wel there..or maybe the updated version is built worse then the older versions..it wouldnt be the first time that a brand 'upgrades' to other parts beccause its cheaper/ easier available..this is all guessingofcourse..i loved my mstage..i had it 2 years without a hitch..with at least 2 hours a day working..i can only say..it gave me a big smile on my face every time i used that little amp!
post #3550 of 4830
Quote:
Originally Posted by hifimanrookie View Post


Oh ok..didnt know that.. Then the quality control is not working wel there..or maybe the updated version is built worse then the older versions..it wouldnt be the first time that a brand 'upgrades' to other parts beccause its cheaper/ easier available..this is all guessingofcourse..i loved my mstage..i had it 2 years without a hitch..with at least 2 hours a day working..i can only say..it gave me a big smile on my face every time i used that little amp!


To say the least I was a little disappointed with the packaging. I mean they used the original box as the shipping parcel. Shame, the box looks really classy/premium. I also liked the M-Stage especially with LM4562 op-amp. Just have to wait and see how they deal with return shipping. I've never had to send anything back before when buying from China/USA. It's gonna suck if I have to bite into expensive shipping costs :S

post #3551 of 4830

Question, did you Class A bias your amp?

post #3552 of 4830

No, I was planning on it but postponed it. I've read that others here ran directly via the 4562 op-amp without any complications. However, I doubt it's due to the 4562 because 2 days ago I tried out the original opamp OPA2134 to see how it sounded in comparison since I havent heard it in a while. Yesterday it was running fine. Today afternoon it worked fine. When I come home to power it on for more this happens.

post #3553 of 4830
Quote:
Originally Posted by muxamed View Post

What do you think about Matrix M-Stage + DT880 Edition 600 Ohms. Would Matrix provide sufficient voltage to these high impendance cans? Any experiences? Thanks.

I have that combo.

The Matrix M has absolutely no problem driving the DT880/600 Ohms to any insane volume you may want.

Personally, I don't like the sound of it too much. A bit too dry, bland and uninvolving for me.

I get more pleasure out of listening to the DT880/600 out of a FiiO E09K (costs half the $$$!).

Out of the stuff I own I usually prefer the DT880/600 Ohm with my La Figaro 336C, which is an OTL tube amp.

post #3554 of 4830
Quote:
Originally Posted by Monir View Post

No, I was planning on it but postponed it. I've read that others here ran directly via the 4562 op-amp without any complications. However, I doubt it's due to the 4562 because 2 days ago I tried out the original opamp OPA2134 to see how it sounded in comparison since I havent heard it in a while. Yesterday it was running fine. Today afternoon it worked fine. When I come home to power it on for more this happens.

 

Very surprising to hear! Wonder if there's any pattern between the two head-fiers who had this issue (possibly in power input) ? 

post #3555 of 4830
Quote:
Originally Posted by elwappo99 View Post

 

Very surprising to hear! Wonder if there's any pattern between the two head-fiers who had this issue (possibly in power input) ? 

 

He had the volume down at Zee-ro went his "event" happened.

 

Not too sure what you mean by "Power Input"?  The 120 Vac line?  He mentioned that his DAC "survived".

 

Hmmmm, guess I better not leave my M on and unattended.

 

Remember, that thing ain't UL approved! No CE mark either. No safety approvals of any kind.


Edited by Chris J - 1/22/13 at 3:56pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Matrix M-Stage amp review: simple, cheap, and excellent.