Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Headstage Arrow HE: Reviews, Impressions, Perceptions & Sensations
New Posts  All Forums:Forum Nav:

Headstage Arrow HE: Reviews, Impressions, Perceptions & Sensations - Page 187

post #2791 of 3080

Now I am worried...

 

Ordered refurb'ed 3G on July 29

Order status says shipped on Sept 7

As of Oct 2, nothing received...

 

Sent multiple emails to Headstage... no reply...

 

Anyone else still waiting for delivery for an order shipped Sept 7 or earlier?

 

Leon 

post #2792 of 3080

@starfly and demonfox

 

This is my first setup/entry to the portable/iem arena. So i am not very adepth on comparing others (because i have none - for now)

 

Was aiming for a high performance, very portable setup.

 

Hoping (basing on reviews, personal research) that:

M2tech's definition, texture, musicality, liquidity (analog like) and open mids will augment

PFE232's fun sounding, detail, clear but slightly V sound.

Plus 4Ts presence, spacious and analog like sound...

 

Everyting just sings! Very analog (M2tech+4T)

 

Of course this comment comes from a beginner.

 

Very happy with my setup:

 

1. I can use the Phone. Close/Open the flip case. Unplug/replug OTG cable to charge.
2. If will not use Phone as a DAP just swap it with my other case.


Edited by m-i-c-k-e-y - 10/3/13 at 2:59am
post #2793 of 3080

@travelfotografe

My Arrow order status said shipped on Sept 7.

Received last week!

Just ask, Lisa might answer you.

post #2794 of 3080
Quote:
Originally Posted by FARfromHOME View Post
 

@travelfotografe

My Arrow order status said shipped on Sept 7.

Received last week!

Just ask, Lisa might answer you.

 

I have been seeing how many here have ordered this batch of refurb'ed Arrows and have received them. Thus my worry as the days of an empty mailbox (empty as in without the Arrow package) dragged on.

 

I have emailed (direct and via the contact us web form) 6 times already since last week, with no reply for the past 10 days now. I will have to keep reminding Headstage everyday that I have not received my order (until I eventually, hopefully, do receive it).

 

I wonder how business for Headstage could have been (so much better) if they could just do better on this time-estimate and customer service front.

 

Leon


Edited by travelfotografe - 10/8/13 at 9:30am
post #2795 of 3080

Lisa did reply last Friday! Apparently they were on holiday (a National holiday) for the first three days of last week. The surprise was she said the package was shipped out last Monday, which is completely different from what was entered in my order status!

 

Anyway, the good news is my refurb'ed G3 arrived today, via DHL from Hong Kong (I am located in Singapore).

 

:etysmile:

post #2796 of 3080
Quote:
Originally Posted by travelfotografe View Post
 

Lisa did reply last Friday! Apparently they were on holiday (a National holiday) for the first three days of last week. The surprise was she said the package was shipped out last Monday, which is completely different from what was entered in my order status!

 

Anyway, the good news is my refurb'ed G3 arrived today, via DHL from Hong Kong (I am located in Singapore).

 

:etysmile:

Nice! Did the package include the 2 ultra low profile interconnects?

post #2797 of 3080
Quote:
Originally Posted by esmBOS View Post
 

Nice! Did the package include the 2 ultra low profile interconnects?

 

Yes my refurb'ed G3 came with the 2 ultra low profile interconnects, which was a pleasant surprise! One shorter and the other slightly longer. Their fit and finish when plugged into the G3 is really perfection, almost like they are part of the casing! The only disappointment is that their cable is rather thin.

 

I am just happy to have my portable rig running again. I lost my portable rig (Fuze V1 rockbox'ed with Fiio LOD into Arrow 3G, fortunately not with my TF10) in a cab, thus had to buy a replacement. Fortunately refub'ed 3Gs are being offered and I ordered one when they were still priced at $149.

 

I have to say that my refurb'ed G3 looks brand new, really nothing to fault in terms of cosmetics.

 

My current rig: Fuze V1 rockbox'ed -> affinitycables LOD -> Arrow 3G -> Westone 4R :etysmile:

post #2798 of 3080
Quote:
Originally Posted by travelfotografe View Post
 

 

Yes my refurb'ed G3 came with the 2 ultra low profile interconnects, which was a pleasant surprise! One shorter and the other slightly longer. Their fit and finish when plugged into the G3 is really perfection, almost like they are part of the casing! The only disappointment is that their cable is rather thin.

 

I am just happy to have my portable rig running again. I lost my portable rig (Fuze V1 rockbox'ed with Fiio LOD into Arrow 3G, fortunately not with my TF10) in a cab, thus had to buy a replacement. Fortunately refub'ed 3Gs are being offered and I ordered one when they were still priced at $149.

 

I have to say that my refurb'ed G3 looks brand new, really nothing to fault in terms of cosmetics.

 

My current rig: Fuze V1 rockbox'ed -> affinitycables LOD -> Arrow 3G -> Westone 4R :etysmile:

 

Thank you! Just ordered a refurbished 3G! Let's seen how long I'll have to wait :D 

post #2799 of 3080

I just Rockbox'd my Clip + which I'm using with Phonak PFE232 IEMs and the Arrow 4G. It seems that the amp hurts the sound and the Clip+ sounds better without it. Is there some settings I should configure on the Clip to help with this? Can anyone suggest some things I should configure to help get the best sound possible with this setup? Thanks!

post #2800 of 3080
Quote:
Originally Posted by rbf1138 View Post
 

I just Rockbox'd my Clip + which I'm using with Phonak PFE232 IEMs and the Arrow 4G. It seems that the amp hurts the sound and the Clip+ sounds better without it. Is there some settings I should configure on the Clip to help with this? Can anyone suggest some things I should configure to help get the best sound possible with this setup? Thanks!

 

I don't have a Clip+, but either way make sure to turn the EQ on the Clip+ off. I don't know if it has a line-out, but if it does definitely use that to connect to the amp. If not, put the volume of the Clip+ fairly low as you want most of the amping to be done by the amp, not by the Clip+.

post #2801 of 3080

@rbf1138,

 

1. when using the 4G, set your clip to 0db, which should be easy to do in rockbox.

 

2. when testing, try to set the effective volume that hear in your PFE to be the same in either configuration. It is easy to find that louder = better.

 

3. what is it about the sound of the Clip+ alone that you find better than the Clip+ with 4G?

 

Actually, this goes to show how good the Clip+ already is, which is why I have twe rockbox'ed clip+ and I am quite happy to use them on their own with my TF10 and W4R. That the Clip+ is a VFM DAP is quite accepted in the community. What I find is that with an external amp like the Arrow, base notes especially are tighter and more textured. Also, an external amp really shows the difference between amp and no amp when using full-sized headphones.

post #2802 of 3080
Quote:
Originally Posted by starfly View Post
 

 

I don't know if it has a line-out, but if it does definitely use that to connect to the amp. If not, put the volume of the Clip+ fairly low as you want most of the amping to be done by the amp, not by the Clip+.

 

The Clip+ has no line out, only HP out. But my understanding from various amp manufacturers and users is when connecting the HP out to an external amp, set the device volume to max or a few steps less than max for best SQ.

post #2803 of 3080
Quote:
Originally Posted by travelfotografe View Post
 

@rbf1138,

 

1. when using the 4G, set your clip to 0db, which should be easy to do in rockbox.

 

2. when testing, try to set the effective volume that hear in your PFE to be the same in either configuration. It is easy to find that louder = better.

 

3. what is it about the sound of the Clip+ alone that you find better than the Clip+ with 4G?

 

Actually, this goes to show how good the Clip+ already is, which is why I have twe rockbox'ed clip+ and I am quite happy to use them on their own with my TF10 and W4R. That the Clip+ is a VFM DAP is quite accepted in the community. What I find is that with an external amp like the Arrow, base notes especially are tighter and more textured. Also, an external amp really shows the difference between amp and no amp when using full-sized headphones.

 

When you say set it to 0db, you mean simply "Volume" set to 0db? I did this and yes, it sounds way better! There are, of course a whole lot more options for setting up volume settings, regarding peaks, frequencies and things like that (which I know very little about and frankly don't understand, lol). 

 

I felt like the Arrow is maybe taking a bit of the air away from the sound, in that its more full sounding but not necessarily in a good way? As if the air had been sucked out of the blank space that was there with only the Clip. I do have the gain set to the | notch. Will this mean making other changes on the Clip settings?

post #2804 of 3080
Quote:
Originally Posted by rbf1138 View Post
 

 

When you say set it to 0db, you mean simply "Volume" set to 0db? I did this and yes, it sounds way better! There are, of course a whole lot more options for setting up volume settings, regarding peaks, frequencies and things like that (which I know very little about and frankly don't understand, lol). 

 

I felt like the Arrow is maybe taking a bit of the air away from the sound, in that its more full sounding but not necessarily in a good way? As if the air had been sucked out of the blank space that was there with only the Clip. I do have the gain set to the | notch. Will this mean making other changes on the Clip settings?

 

Yes, set the volume to 0db. Now be careful if you ever plug ur headphone back into the Clip+ with volume set to 0db, because that is freaking loud (VERY loud) and will hurt your ears and hurt your IEM and most likely both.

 

I personally do not like to apply equalization (i.e. compensation at different frequency bands). you should only experiment with that after you have exhausted all other adjustments

 

You should not be setting the gain to the | notch. gain is O, I or II right? set it to O, and increase the volume on the Arrow. with IEM, you should use the lowest gain for lowest noise. Try it!

 

Start with all settings on the arrow to O first.


Edited by travelfotografe - 10/9/13 at 8:16am
post #2805 of 3080

"If not, put the volume of the Clip+ fairly low as you want most of the amping to be done by the amp, not by the Clip+."

 

That's incorrect, right? I always thought (like travel says) that the volume should be very high on the source player.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Headstage Arrow HE: Reviews, Impressions, Perceptions & Sensations