Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › RE2 Sounds closed and stuffy
New Posts  All Forums:Forum Nav:

RE2 Sounds closed and stuffy

post #1 of 7
Thread Starter 
Just got my RE2s, out of the box they sound pretty terrible. Not much going in the highs to speak of, mids are okay, and bass is really undefined.

The whole thing sounds muffled and stuffy. It is as if I'm listening to the signal behind a wall.

Does anyone know if this is normal, and burn in will fix this?

My seal is good, I'm using Comply T400s, and I tried the stock flanges, same type of sound.
post #2 of 7
That's weird, is all I can say. My RE2's bass is weak, yes, but its mids are good, its highs are great, and it certainly doesn't sound muffled or stuffy.
post #3 of 7
Thread Starter 
So will these sound okay without an amp? Your review mentions an amp..

Sinocelt, who is that in your Avatar Pic? Looks like an actor
post #4 of 7
I dont think burn-in will help any with the muffled highs. Maybe its the adjustment from your other IEM's.
post #5 of 7
Coming from the ear-piercing treble of the S4, the RE2 would sound muffle I suppose.
post #6 of 7
You could always try ClieOS' RE1 treble mod on the RE2.
post #7 of 7
Thread Starter 
Just did ClieOSs mod, seems to help a little. I will wait till these cook before make a judgment.

I guess I shouldn't be comparing them my higher end BAs, some of the reviews talked about how transparent the RE2s sounded
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › RE2 Sounds closed and stuffy