Head-Fi.org › Forums › Equipment Forums › Computer Audio › How do i setup foobar with wasapi? (i see no option in output
New Posts  All Forums:Forum Nav:

How do i setup foobar with wasapi? (i see no option in output

post #1 of 10
Thread Starter 
there seems to be a lack of info on how to do this, maybe it's too simple.

here is a video of what i'm talking about, is wasapi already being used?
MEGAUPLOAD - The leading online storage and file delivery service

i moved the file in to components folder of foobar, but under output menu I don't see it.
post #2 of 10
I wouldn't be able to help you any further then what I've experienced.

All I did was copy the .dll into the components folder, I made sure foobar was closed before copying it over, after I copied the file over I opened up foobar and browsed to File->Preferences->Components.

Select WASAPI: (Your output device) ASUS Xonar Essence STX and it was done.

Have you tried re-installing foobar? I'd recommend using ccleaner for the uninstall just to make sure no files are left over, and also you can scan for registry files not in use anymore in ccleaner, after you uninstall foobar of course.

After that I would go ahead and just start the process over and see where it gets you, if that doesn't work I'm sure someone more helpful will come along.

Happy new year.

EDIT: I forgot to mention, make sure your device supports WASAPI (I could be wrong on this) but I know that before I installed my sound card I tried setting this up with onboard and it didn't show up at all.
post #3 of 10
Download the file from here:
foobar2000: Components Repository - WASAPI output support

unzip it and put the .dll file into folder foobar2000/components/
restart foobar and you should see wasapi under output
post #4 of 10
post #5 of 10
The problem is that according to the video, you're using Windows XP, which doesn't support WASAPI. You need Vista or Win 7.

Try the Kernel Streaming plugin instead: foobar2000: Components Repository - Kernel Streaming support
post #6 of 10
Quote:
Originally Posted by SirDrexl View Post
The problem is that according to the video, you're using Windows XP, which doesn't support WASAPI. You need Vista or Win 7.

Try the Kernel Streaming plugin instead: foobar2000: Components Repository - Kernel Streaming support
Boom - end of Thread
post #7 of 10
Quote:
Originally Posted by SirDrexl View Post
The problem is that according to the video, you're using Windows XP, which doesn't support WASAPI. You need Vista or Win 7.

Try the Kernel Streaming plugin instead: foobar2000: Components Repository - Kernel Streaming support
I'm currently using asio4all with foobar in winxp. Is this better or worse than kernel streaming support? Or are they completely different entirely?
post #8 of 10

Can 24-bit source material be fully enjoyed on Windows XP?

I read up about the kernel streaming plugin at the link provided, and in an article posted with it, it said that XP processes audio in it's kmixer in 16-bit integer format.
Does that mean that to get what's expected from 24-bit material that we have to upgrade to Windows 7?
post #9 of 10
Quote:
Originally Posted by Zerotohero View Post
I'm currently using asio4all with foobar in winxp. Is this better or worse than kernel streaming support? Or are they completely different entirely?
It's almost exactly the same thing, just a different method. If you hear a difference, it's placebo or you're doing something wrong.

Quote:
Originally Posted by mrB View Post
I read up about the kernel streaming plugin at the link provided, and in an article posted with it, it said that XP processes audio in it's kmixer in 16-bit integer format.
That's why we bypass kmixer with Kernal Streaming / ASIO. (IIRC how it works)
post #10 of 10
I just did the same and it worked for me.

A short summary of what I did:

1) Download the file here: foobar2000: Components Repository - WASAPI output support and extract the .dll file to the components folder. (make sure Foobar is shut down during this process)
2) Start Foobar, got to File -> Preferences and click Components. If done correctly you should now see WASAPI Output Support somewhere in the list of found components.
3) Now go to Playback under the Preferences tab and click Output, now select WASAPI:...(whatever setup suits your current)... under the Output Device scroll down window.
4) Once you've selected the correct setup click Apply followed by Ok, reboot Foobar and it should work!

Hope this has clearified any possible doubts about how to do this ;-)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › How do i setup foobar with wasapi? (i see no option in output