or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps ›  iBasso D42 "Mamba" with dual dacs! !! Hey Hey! Improved Starting on Page 76 .
New Posts  All Forums:Forum Nav:

iBasso D42 "Mamba" with dual dacs! !! Hey Hey! Improved Starting on Page 76 . - Page 56

post #826 of 1153
Arctic - you might have a ground loop engaged. With my MacBook Pro, I get very little hiss either battery powered (amp or DAC) or via USB even when fed by the mains. However, if I have the amp in certain positions, it will pick up ground loop and hum - and that is horrid.

Saying that, I currently have the TopKit installed - without it, there is heavy hiss in all situations with my iems.
post #827 of 1153
I have gone through the entire thread and have made up mind to get the D4 Mamba .I have final questions regarding the opamps.

1)What are topkit opamps?
2) Is it worth to get the op amps from ibasso site ??,there is a set in the accessories section of iBasso site.

Cheers...
post #828 of 1153
Finally ordered the D4 Mamba just cant wait to get it to my hands wish i had the money to fly to Hong kong and pick it up :P

Thanks to all the head-fiers you reviews and impressions helped me choose the one of the best amps till date.
post #829 of 1153
I just got one for my laptop. Sound Crystal clear even without Burn in! Burning in in progress. a happy user of D4.
post #830 of 1153
Just got one for my macbookpro. Very, very happy with it so far. Beautiful, clear, precise sound, excellent bass, good timbre - the cellos on one of Mozart's string quartets had such resonance after the notes were played! Loving it. Recognized by the computer immediately without doing anything - fantastic. I went ahead and got HiFlight's 'topkit', so hopefully will be making it even better! Will report back.
post #831 of 1153
Got my D4 Mamba .Oh boy oh boy its tiny and sounds amazing right out of the box,it pairs perfectly with the Re1 .Its a VFM product .Deep bass,mods are sounding great .Thanks to headfiers
post #832 of 1153
Its mods are a great way to change certain signatures. I still have the topkit installed and love it.

Is anyone else having ground hum issues? If I hold the amp, there are none, but when connected via USB, I've been getting some baddies lately.
post #833 of 1153
My D4 is on it's way to the land of the vikings! At least I hope it is - no word from iBasso since I ordered it yesterday afternoon :/
post #834 of 1153
Just got my D4 today, this being my first real amp(E5 not really counting). I was wondering what the gain switch does and what setting I should have it on?

Also, does this require burn in? The bass is a bit loose out of the box with my Westone 3...
post #835 of 1153
My D4 finally arrived after exactly 3 weeks! This is very good amp to pair with my HD595, sounds good right out of the box, and hopefully will get better after some burn-in.

However I can't set ASIO4ALL to work with it. I get an error message on foobar start up regarding the number of channels or something, and the DAC shows up on the ASIO software list but it's unavailable (it has a red cross on the DAC icon). Help?! =(
post #836 of 1153
Quote:
Originally Posted by malalol View Post
My D4 finally arrived after exactly 3 weeks! This is very good amp to pair with my HD595, sounds good right out of the box, and hopefully will get better after some burn-in.

However I can't set ASIO4ALL to work with it. I get an error message on foobar start up regarding the number of channels or something, and the DAC shows up on the ASIO software list but it's unavailable (it has a red cross on the DAC icon). Help?! =(
Go to foobar preferences and go to ASIO and there I think u have to assign a left and right channel. I dont exactly remember how it goes but its pretty intuitive
post #837 of 1153
Oh my god, 3 weeks? Where do you live, mars?

Quote:
Originally Posted by malalol View Post
My D4 finally arrived after exactly 3 weeks! This is very good amp to pair with my HD595, sounds good right out of the box, and hopefully will get better after some burn-in.

However I can't set ASIO4ALL to work with it. I get an error message on foobar start up regarding the number of channels or something, and the DAC shows up on the ASIO software list but it's unavailable (it has a red cross on the DAC icon). Help?! =(
post #838 of 1153
Now I got it, had to disable SW Synth Wave input from Windows speaker panel, also disable/enable the ASIO on foobar preferences.

It's wonderful now! The amp is VERY tiny, but it makes a whole lot difference, not the night and day difference I was expecting, but it makes every describable sound element better (treble, extension, bass, separation, transient, etc.), so it's an all-round SQ improvement device!

And it's straight out of the box! I've heard even the DAC needs 24-48h to open a bit and settle down, so this is really a winner. Plus I want to order the HiFlight topkit when my bank account recovers

And I don't live in Mars, I live in Brazil D4 took a whole week to fly, and later I found a detailed tracked in Chinese (Google translator is your best friend in situations like this) and saw my D4 went to London before coming to Brazil, well...
post #839 of 1153
me thinking that the high gain setting is more transparent is purely psychological right?
post #840 of 1153
Thread Starter 
Quote:
Originally Posted by playingwithfire View Post
me thinking that the high gain setting is more transparent is purely psychological right?
Only you can say. Time with it will be the best thing and if it is the most transparent in high gain I am sure that with further listening you will know.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps ›  iBasso D42 "Mamba" with dual dacs! !! Hey Hey! Improved Starting on Page 76 .