Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Maverick Audio DAC/Amp
New Posts  All Forums:Forum Nav:

Maverick Audio DAC/Amp - Page 171

post #2551 of 2616

Anyone?

post #2552 of 2616

I was thinking about one of the D1+ DAC/amp units or a Aune T1 would anyone have any idea which one is better?

post #2553 of 2616

Can't comment on which is better but I was deciding the same thing before I bought the Maverick Audio D1 Plus. Ultimately decided on the Mav Audio due to its input options as well as esthetic finish. To me, the Maverick Audio just looks more professional albeit "entry level" DAC. 

 

I bought it with the GE and OPA627 upgrades. Two days after receiving the unit, I decided to purchase the WE JW 2c51 396A tube and have not turned back since. It's an overall beautiful unit.

 

Currently setup:

 

Macbook Air + 27" Thunderbolt Display --> Maverick Audio TubeMagic D1+ --> KRK Rokit RP5G2.

 

Prior to using this setup, I've tried numerous combos of DACs including EMU 0204, Schiit Audio M&M Stack, Nuforce UDac2 plus numerous Studio Monitors such as the Mackie MR5MKII, Audioengine A5+. 

 

So far, this is the best setup I've liked thus far. Finally starting to enjoy my music rather than always looking to move up in the price bracket to try and "upgrade."

post #2554 of 2616

My D1 has finally just stopped putting out any sound at all. Still waiting on a response from Maverick Audio :(

post #2555 of 2616

Neither surprises me.  I had the D1 and it was a huge disappointment with some manufacturing defects.  Rather than fixing it, Ryan offered me $40 to shut up.  Good luck.

 

Quote:
Originally Posted by Zaluss View Post

My D1 has finally just stopped putting out any sound at all. Still waiting on a response from Maverick Audio :(

post #2556 of 2616

Also had a similar problem where the left channel on my D1 died. Reseated the OPAMP and it was fixed, but then later the headphone out was shot (it was terrible as a standalone amp anyways). But yeah I agree that its a very shabby unit that I wouldn't recommend to others. 

post #2557 of 2616
Quote:
Originally Posted by hodgjy View Post

Neither surprises me.  I had the D1 and it was a huge disappointment with some manufacturing defects.  Rather than fixing it, Ryan offered me $40 to shut up.  Good luck.

 

 

Thats disappointing. Sadly I still haven't received any word from Maverick about it. I tried multiple channels of communication with no avail. My first email noted that I was also interested in the A1 to combo with my D1 but since the lack of response I decided to pick up a CA 640A v2 for cheap on Audiogon. There is a local repair shop here in Seattle willing to look at it so I may take it there. 

Quote:
Originally Posted by junkimchi View Post

Also had a similar problem where the left channel on my D1 died. Reseated the OPAMP and it was fixed, but then later the headphone out was shot (it was terrible as a standalone amp anyways). But yeah I agree that its a very shabby unit that I wouldn't recommend to others. 

 

I'll try reseating the opamp. I took it apart already to check for shoddy solder but didn't see anything. 

post #2558 of 2616

Zaluss, 

 

Any news on getting your unit repaired?

post #2559 of 2616
Quote:
Originally Posted by tranv117 View Post

Zaluss, 

 

Any news on getting your unit repaired?

I haven't gotten a chance to bring it in. I also still haven't heard anything from Maverick Audio/Ryan so I've pretty much given up on that. Real shame considering I really liked the unit.

post #2560 of 2616
It Sucks hearing people having bad luck with their D1.frown.gif I k kw the early production units were finicky but figured by now it'd be okay. Best of luck to those needing repairs.
post #2561 of 2616

Hi. I need advice from experience D1 users.

 

1) My D1 works perfectly, I just wanted to replace the LED. But my new LED keep dying! Sounds funny but I already burnt 5 LEDs. I have checked the LED terminal using mutimeter. DC setting on multimeter reads nothing but the multimeter's needle vibrate as it reads AC voltage. On AC setting, it reads 6.5VAC? 

 

2) Whenever I turn ON/OFF any switch in my room, the USB connection reset! There is a loud static sound come through speaker. It was very annoying while watching movies. 

 

Have any of you encounter these problem before?

 

Thanks.

 

post #2562 of 2616

What do you mean by the USB connection resets? If a connected device powers off; the computer will no longer see it as a connected device.

post #2563 of 2616

It was like unplug and plug back the USB. The sound went to my laptop speaker and after a while (maybe after reconnect the device) it went back to my A5.

post #2564 of 2616

Anyone interested in buying a Maverick Audio TubeMagic A1 amp, D1 or D1Plus Dac/Amp, or the D2 DAC....price considerations.

 

Maverick Audio has always offered upgraded OPA627 OpAmps and NOS GE 5670W tubes for their line, but they tended to be a bit expensive compared to mods you could do on your own. It looks like they've taken notice, and started offering package pricing with the mods on their products across the board. The link is

 

http://mav-audio.com/store/

 

Additionally they are offering an additional $15 off any product using the check out code "15OFF". I just picked up a D2 DAC with all upgrades and shipping for under $300, after the $15 off. A bit less than it would have been a few months ago.

post #2565 of 2616

Are people still having problems with these?  They look like a great option on paper, checking off everything I'm looking for.  But if they're built poorly and have poor support, I'd just as soon spend an extra few bucks on something that won't break...

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Maverick Audio DAC/Amp