Head-Fi.org › Forums › Equipment Forums › Gear-Fi: Non-Audio Gear and Gadgets › Strange Mac internet browsing problem
New Posts  All Forums:Forum Nav:

Strange Mac internet browsing problem

post #1 of 4
Thread Starter 
Hi guys, I'm traveling around asia and australia right now, using my macbook to access the internet. I got a strange problem here using the browsers on my mac (Firefox and safari). On several places, the browsers always unable to get me to the website which I want to visit, instead it directs me to a search engine. It only happens on the osx browsers, I did not encounter the same problems when I use the browsers my windows even when I use my vmware fusion. So I was forced to use my vmware fusion and using the windows internet browser to surf the net. Do you have any idea what caused my osx browsers to behave this way? Do I get any virus or trojans on my mac? It only happened on several places, I never encountered this problem in US.
post #2 of 4
how are you connecting to the web? i used to get a problem with hotmail on 3g modem, msn would be most insistent that i was on a mobile so would only give the msn mobile page. does it do this with wifi or 3g / HSPDA or both? i would look at who is offering the internet to you first.
post #3 of 4
Almost sounds like they are pointing to different DNS servers. Do you know how to check the DNS server settings?
post #4 of 4
^^ You could try setting your DNS servers to opendns to see if it helps, their servers are:
208.67.222.220
208.67.220.222
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Equipment Forums › Gear-Fi: Non-Audio Gear and Gadgets › Strange Mac internet browsing problem