New Posts  All Forums:Forum Nav:

Whiplash Audio - Page 3

post #31 of 304

I'VE BEEN WAITING 2 MONTHS!!!!

 

I placed an order on May 17 for a mini to mini cable w/ oyaide right angle connections.  As of today I still have not received it.  After a month of not hearing anything about my order I finally contacted Craig by email to see what's up.  He tells me they've been really swamped lately and are a little behind.  Then tells me it will go out in a few days(I'm ok with this).  Well, 2weeks went by, and still nothing.  So I decided to call this time, and this time he tells me they've been at some MEET/SHOW for the last 10days(I guess he couldn't of told me about this in the last email).  However, I'm told it will definitely be shipped in a couple days.  Its been more than a week now, and still no signs of being shipped.  I called again today but no one answered.  I did leave a voicemail, but haven't heard back yet.  I was hoping to get the cable before I moved, but it doesn't look like that's going to happen.  Move date is early Saturday morning(7/16) and it's out of state.

post #32 of 304

Received email from paypal today informing me that Whiplash has shipped my order!  I guess posting a negative comment on a public forum forces someone to take action.  Though, I doubt I'll get it in time.  All USPS is saying "electronic info received". 

post #33 of 304

Oh how wonderful.  Whiplash finally decided to drop the package off at the post office today, so another day was wasted cause of laziness(should of expected this).  Paypal sent email around noon yesterday saying label was created.  As a result of this laziness, I will not receive my package in time.  So now I get to pay to have it reshipped, YIPPEE!!

post #34 of 304

I have been waiting for 6 months and still nothing has been shipped !!!!!!!!!!!!!!!!!mad.gif

 

order more than just cables,  send many e-mails but nothing is really happening !!!

 

don't what to do anymore this is really getting frustrating !

 

any recommendation on how to handle this ???

post #35 of 304

 

It actually seems like communication is very inconsistent. There are extremes of both hits and misses. The Whiplash forum has recently had a juxtaposition of glowing praise with almost equally matched complaints. I guess I'm one of the more unlucky ones... 

Back when I bought my AMP3 from Whiplash, customer service was top notch. Emails were replied to within minutes and everyone was happy. In January of last year, my AMP3 went defective (like many others) and I sent it in. Although it was under warranty, I couldn't get a replacement since the company that made the AMP3 discontinued the product. Craig was nice enough to let me wait for the revisions of the AMP3 or get a deal or arrangement on some of his own products. I asked for whatever arrangement he could make on some HFI-580s in his store, and that was the end of it. A year and a half later, I still have nothing, maybe 25+ emails exchanged with like 20 of them unreplied to. The last I heard, 2 months after I asked for a deal on the HFI-580, he said he put an order in. Finally... however, this was back in March of this year. I've waited so long I've pretty much given up. I know they're very busy, but this is insane. I even tried to get ahold of him on Head-Fi and finally got a PM asking for my name and email, but then nothing else. Good grief, all I want to know is what happened here...
 

Quote:
Originally Posted by grokit View Post

Communication can be a bit inconsistent but Craig is a very good vendor. He replaced my Ed8 drivers under warranty and it took longer than expected so he made me an offer I couldn't refuse on a TWagV2 re-cable, and I must say that I was a bit skeptical at first but this is a really great-sounding cable. I don't really notice the difference if I use an adapter or extension (I just went for a stock 4' replacement with 1/8" plug like the original Ed8 cable) at home, but when I am listening to it straight out of my portable amp with its Oyaide rhodium plug it's flat-out amazing. I miss the more flexible ergonomics of the stock cable but I am getting used to the TWag, it's not really that stiff just stiffer that the stock cable and the sound really is incredible. I highly recommend Whiplash Audio and the TWagV2, thanks again Craig.


 

post #36 of 304

As much as it pains me to say it. I retract my previous statement...

I've been waiting almost a month for a shipment that was supposed to take 3-5 working days, and now Craig won't even respond to my emails.

 

I'm giving him 1 more day before I lodge a paypal dispute.

 

All I'm asking him to do is call USPS and get some information but he won't respond.

 

I got this from him this morning after sending 6+ emails with information from Australia Post and USPS saying I need the sender to chase the issue up, and receiving no reply.

 

"Hi Adam,

 
Last time I checked they says it was at customs. I'm traveling today so i will have my employee check....
 


Sorry for delay. I can't see a reason why it's being held up....

 
Thank You,
Craig Sanborn"
 
This annoys me for 2 reasons (one is petty i know)
Firstly, my name is Aaron...
Secondly, customs in Australia has no record of it. At all. Tracking says it's still in New York.
 
I'm very annoyed.
 
$1200 and he won't even reply to an email. I'm not normally this critical and like to give positive and constructive feedback, but honestly. I can only recommend staying away at this stage.
 
Sorry Craig, but you really haven't done anything to help me, and this is a substantial amount of money for me.
 
Aaron

Edited by Acesi7 - 7/25/11 at 5:19pm
post #37 of 304

It happened to me with ebay once.

 

The sender provided electronic info about the shipment, which actually took place a month later and only after I complained to ebay.

 

A seller can give you tracking info but it doesn't actually mean the package has shipped.

post #38 of 304
Quote:
Originally Posted by rosgr63 View Post

It happened to me with ebay once.

 

The sender provided electronic info about the shipment, which actually took place a month later and only after I complained to ebay.

 

A seller can give you tracking info but it doesn't actually mean the package has shipped.




I'm really not sure what's going on, craig has finally gotten back to me and said he has lodged a query with USPS and should hear back in 1-5days, they told him they think it's in Melbourne Australia (or so he tells me). But Australia Post and Customs here have no record of it entering the country. So I don't know who or what to believe. All I know is I'm facing losing $1200 so I'm not taking any chances and will lodge a PayPal dispute if I don't have any solid information at the end of the 5 days.

post #39 of 304

 

Quote:
Originally Posted by Acesi7 View Post


I'm really not sure what's going on, craig has finally gotten back to me and said he has lodged a query with USPS and should hear back in 1-5days, they told him they think it's in Melbourne Australia (or so he tells me). But Australia Post and Customs here have no record of it entering the country. So I don't know who or what to believe. All I know is I'm facing losing $1200 so I'm not taking any chances and will lodge a PayPal dispute if I don't have any solid information at the end of the 5 days.


You should be able to track it online with the number on the customs form once it's in your country. But by all means file a dispute before the time limit runs out, you don't have to elevate it to a claim if things end up working out you can just cancel it instead.

 


Edited by grokit - 7/27/11 at 1:11am
post #40 of 304
Quote:
Originally Posted by grokit View Post

 


You should be able to track it online with the number on the customs form once it's in your country. But by all means file a dispute before the time limit runs out, you don't have to elevate it to a claim if things end up working out you can just cancel it instead.

 

Cheers grokit,

I've got in touch with Craig who informs me he was away. And I'm satisfied that he is now following this issue up. I'll give him a little more time before taking it any further and the benefit of the doubt. But would really like to see some progress or at least a reason for the delay from USPS shortly as this is getting ridiculous...
 

 

post #41 of 304

Craig received my TWag V1 balanced IEM cable on 7/5/11 for replacement, and I received the new V2 cable on 7/28/11.  I pestered him for faster delivery, but the problem was with a bad shipment of over mold cable that he received, so I went with the standard non-over mold cable like my original to get it faster.  My deadline was this next Friday, to have it time for the Colorado meet on the 7th, and he delivered in spades.  Thanks Craig!

post #42 of 304

All items have now arrived, and while I'm not convinced Craig chased anything up with USPS. All is now in my posession. Why there was a huge delay from USPS I guess I'll never know. But craig did sort everything out with me and attempted to make things right in the end. So all in all, not a good experience. But not as much Craig's fault as USPS. But I do feel craig should have got on USPS' back a little more. Either way, it's all done now. And all items are masterfully crafted and the kind of quality I would expect for the price. Let the burning in and Audio Nirvana begin. :D

post #43 of 304

Deleted


Edited by garetjax1 - 9/13/11 at 6:34am
post #44 of 304

Still from my last post well over a month and a half ago still no confirmation that anything that i ordered has been shipped.  Although he contacted me shortly after i complained and told me that he will take care of it and through in a free cable which is useless if i have been waiting 7 months already.angry_face.gif  i just want my order sick and tired of chasing is it ......!!!!!!!!!!!!!!!!!

post #45 of 304

Well, I took the time to write up negative feedback, so it's only fair now that I write up some positive...

 

I just ordered a TWag v2 Eclipse IEM OM cable from Craig (which craig provided at a significant discount as an apology for our previous transaction beerchug.gif)

Now craig responded to each and every one of my emails within a few hours, which to me is especially impressive given the time difference between him and me. There was a delay in shipping out the item (only 3-4 days and was due to awaiting a shipment of Oyaide connecters) which Craig told me about straight away, so I wasn't left in the dark. And once I received the shipping notice the item was on it's way immediately. Item has travelled smoothly and is now awaiting my pickup at my post office (wasn't home when courier tried to drop it off mad.gif).

 

So I can only say that this transaction with craig was perfect. In almost every sense of the word. He was very generous with his discount to make up for our previous issues, and this transaction went off without a hitch.

 

Thanks Craig!

 

Shipping info:

 

 

Quote: from USPS
Customs clearance processing complete, September 14, 2011, 5:11 pm, AUSTRALIA
Customs Clearance, September 14, 2011, 3:06 pm, AUSTRALIA
Processed Through Sort Facility, September 14, 2011, 3:05 pm, AUSTRALIA
Processed Through Sort Facility, September 10, 2011, 1:34 pm, ISC NEW YORK NY(USPS)
Arrived at Sort Facility, September 10, 2011, 1:33 pm, ISC NEW YORK NY(USPS)
Processed through Sort Facility, September 09, 2011, 7:58 pm, ROCHESTER, NY 14692
Electronic Shipping Info Received, September 09, 2011
Acceptance, September 09, 2011, 4:49 pm, PENFIELD, NY 14526

 

 

Quote: from Australia Post

16/09/11 07:38 Onboard with driver FERNTREE GULLY DC
16/09/11 07:34 Processed at facility FERNTREE GULLY DC
14/09/11 17:11 Transferred for delivery processing - Vic AP Metro Delivery  
14/09/11 15:05 Received and awaiting clearance for delivery  
10/09/11 13:34 Processed - enroute to final destination  
10/09/11 13:33 Received and ready for processing  
09/09/11 16:49 Item lodged

 


Edited by Acesi7 - 9/15/11 at 4:31pm
New Posts  All Forums:Forum Nav:
  Return Home