New Posts  All Forums:Forum Nav:

Where's Whiplash?  

post #1 of 10
Thread Starter 
Anyone know if something's up with Whiplash Audio? I place an order on April 16 and all contacts are not responding...
post #2 of 10
Quote:
Originally Posted by jehugo View Post
Anyone know if something's up with Whiplash Audio? I place an order on April 16 and all contacts are not responding...
Craig is on a well deserved vacation, give him a few days to respond.

Lee
post #3 of 10
Thread Starter 
OK thanks for the info
post #4 of 10
Sooo Sorry!!

I was in Cancun with my family. I did check emails and it seems like some never made out of Mexico.

That silly Swine Flu.

At any rate, I'm back!!
post #5 of 10
Glad to hear back from you, Craig!
Hope it was a good vacation.
post #6 of 10
It was! Thanks for asking. Playa De Carmen is awesome and the drinks are even better!!
post #7 of 10

anybody knows where craig is? i just bought few rsa protector balanced connectors from him 3 days ago and after sending him confirmation email, i haven't heard from him again.. frown.gif

post #8 of 10
Quote:
Originally Posted by i_djoel2000 View Post

anybody knows where craig is? i just bought few rsa protector balanced connectors from him 3 days ago and after sending him confirmation email, i haven't heard from him again.. frown.gif



Same, sent more than 2 emails to Craig about my order that was placed on Nov, 4, but I don't have any replies yet.......  frown.gif

post #9 of 10

Ok guys...

 

Back on line..

 

Please reply back to me and I will take are of you.

 

Craig

post #10 of 10

How long does it take to ship?  Ordered a twag cable for ie8 over a week ago and no response to my inquiry regarding that.


Edited by Headphony - 3/31/11 at 3:40am
New Posts  All Forums:Forum Nav:
  Return Home
This thread is locked