New Posts  All Forums:Forum Nav:

Phonak Audeo Defect Thread - Page 4

post #46 of 467
And this is mine.

post #47 of 467
Quote:
Originally Posted by soozieq View Post
If your Phonak's are functioning as they should be, that's great, but please don't post it here
You're absolutely right, sorry about that! I hope I won't have to post again on this thread!
post #48 of 467
Thread Starter 
Quote:
Originally Posted by radagast85 View Post
You're absolutely right, sorry about that! I hope I won't have to post again on this thread!
Ha ha, it's okay. I didn't mean not to post in the thread at all, just not to post specifically that your Phonaks are free from defects

Otherwise, join in. I'm kind of strangely fascinated as to why the crack most often starts at the bottom of the earpiece, and why only the left side??

Quote:
Originally Posted by tstarn06 View Post
Sorry to intrude. Last time.
Don't be silly. You're welcome to post in this thread. It's about defective Phonaks, we're not talking about earphone preference here. We're safe! I didn't word my post very well when I said people should refrain from posting if their Phonaks are defect free. See my reply to radagast85 above.

Quote:
As an FYI, I thought the other owner of the white phones, forget who, had a damaged cable out of the box,
but didn't suffer the weird cracking the black phones have.
Could be wrong about that.
Thanks, I'll check. I do remember the cracked cable post, and I'll correct it if it's wrong. It's best to keep the information as accurate as possible.
post #49 of 467
Always the same spot on the left earpiece, obviously some sort of stress+weakness in that one spot. Should be easy for phonak to get to the root of the problem. I do wish they would post here, It would put a lot of us at ease if we knew they had a handle on it. Especially since I'm getting a 3rd pair! I'm a glutton for punishment
post #50 of 467
Thread Starter 
Quote:
Originally Posted by Ihatepopupads View Post
Especially since I'm getting a 3rd pair!
I'm a glutton for punishment
Yeah, but I got my W3's three times before you got your Phonaks three times.

You're always one step behind
post #51 of 467
Quote:
Originally Posted by soozieq View Post
Yeah, but I got my W3's three times before you got your Phonaks three times.

You're always one step behind
Lol, so true
post #52 of 467
I have to wonder how some of you are inserting these things.

I simply give the Shure Olives a squeeze, hold the silver part, and then gently push in.

So far, no defects to speak of.
post #53 of 467
My pfe is black and left earpiece cracked. Action: Replacement.
post #54 of 467
Mine were black, for the record.
post #55 of 467
noob here, I bought FPE base on reading through all the Phonak thread. it sounds wonder but the right channel died on me on the 16th day after using it. I got my replacement arrive 5 days after reporting this to Audeo. I bought IE7 to have 2 IEMs in case any one of them failed, I cannot stand the NYC Subway without a good IEM
post #56 of 467
Yea that hole seems to be quite common on the defected PFE's. After I saw a picture of the same thing in another thread, that was when I decided to give Phonak an email.

@soozieq: My new pair is the same model - Black PFE's, minus mic, and (knock on wood) minus gaping hole.
post #57 of 467
Quote:
Originally Posted by schneller View Post
I have to wonder how some of you are inserting these things.

I simply give the Shure Olives a squeeze, hold the silver part, and then gently push in.

So far, no defects to speak of.
Lol funny, Yes were all just manhandling them to death. We don't know how to take care of stuff or insert iem's. Couldn't be a defective run of product noooooooooooooooooooooooo!
post #58 of 467
Oh soozieq, I was actually an owner of the White PFEs...not the black. Thanks
post #59 of 467
Thread Starter 
Quote:
Originally Posted by Hsiu View Post
noob here, I bought FPE base on reading through all the Phonak thread. it sounds wonder but the right channel died on me on the 16th day after using it. I got my replacement arrive 5 days after reporting this to Audeo. I bought IE7 to have 2 IEMs in case any one of them failed, I cannot stand the NYC Subway without a good IEM
Hi Hsiu, hope the replacement pair stays good for you

By the way, do you have the black pair or the the white pair?

Thanks everyone else for the colour updates and the pics.
post #60 of 467
I believe both HiFlight and jleewatch have gotten replacement PFEs. I know HiFlight did, because he posted it in the Yuin G1A thread (he did a review of the Yuin clips) and jleewatch posted that he re-bought them (after sending them back for a refund). You can check with them, but I read those posts.
New Posts  All Forums:Forum Nav: