New Posts  All Forums:Forum Nav:

Phonak Audeo Defect Thread - Page 23

post #331 of 467
Quote:
Originally Posted by Thrashingshrimp View Post
Bill tends to take several days to respond.
Joshwin,

I received your last email on 9/21 at 8:52pm and responded on 9/22 at 8:06am. That's one day not several days. Just responded to your email dated 9/23 at 7:46pm.

Thanks,

Bill
post #332 of 467
I received my PFE 112's with the right channel DOA.

I'm still waiting on a reply from Bill on my PM.
I'm wondering if he can help me or if I should contact someone else, since I live in The Netherlands.
post #333 of 467
Quote:
Originally Posted by Davx View Post
I received my PFE 112's with the right channel DOA.

I'm still waiting on a reply from Bill on my PM.
I'm wondering if he can help me or if I should contact someone else, since I live in The Netherlands.
Please send your order details to orders at audeo-online.com and we'll see what we can do.

Bill
post #334 of 467
Quote:
Originally Posted by DeTrun View Post
I was wondering, is there someone who also has purchased a PFE from Hören mit Fiebing and after their PFE failed, also requested and received a refund? What did you do?
I did, they told me that they have never received my earphones and refuse to do anything
post #335 of 467
Well, They have told me to send me the PFE's before they will refund my purchase.

Quote:
Originally Posted by mierenneuker View Post
I did, they told me that they have never received my earphones and refuse to do anything
Oh, that's not good to hear, sorry.

I also had some problems with my first pair, but it was because of various circumstances regarding my PFE (, which was also the reason why I received my replacement quite late, they had to discuss it with the manufacturer ). But they did receive my pair of PFE's, quite fast.

Was it the first time you have sent something to Hören mit Fiebing or had you already sent them your PFE for a replacement?
post #336 of 467
Quote:
Originally Posted by wbrownie View Post
Joshwin,

I received your last email on 9/21 at 8:52pm and responded on 9/22 at 8:06am. That's one day not several days. Just responded to your email dated 9/23 at 7:46pm.

Thanks,

Bill
Thanks for replying now. I was talking about the emails I sent to you on September 18th. I'm guessing you just never saw them or something.

Thanks though, hope the new shipment arrives soon.
post #337 of 467
Oh no....I just received my new white PFE...the batch is from 9-16-2008....one of the defective batches. Nothing has happened yet....I've only worn them a couple of times. I got these through one of the authorized dealers in amazon.com. I haven't sent in my warranty information yet...no particularly sure how strict they are on that..
post #338 of 467
Great, I just found that the outer cable of my left PFE has broken, exposing the bare cables.
That means I'm without headphones for at least a month (ok, there still are those crappy Apple earplugs...), since I'd like to wait for the new version (and the one with mic again).
I don't remember the batch number of the ones now broken, however I stated it some time ago in the happy post about the fast replacement...
post #339 of 467
Phonaks imo have the fastest and best support of audio companies
hopefully the new batches arrive soon
post #340 of 467
Quote:
Originally Posted by swaneon View Post
Phonaks imo have the fastest and best support of audio companies
hopefully the new batches arrive soon
Yes, customer support is phenomenal.
post #341 of 467
Quote:
Originally Posted by Davx View Post
I received my PFE 112's with the right channel DOA.

I'm still waiting on a reply from Bill on my PM.
I'm wondering if he can help me or if I should contact someone else, since I live in The Netherlands.
Bill contacted Phonak Switzerland who contacted Phonak Netherlands.
I received my replacement PFE 112's yesterday, although from an older batch than the defective ones.
It's working well so far.
post #342 of 467
By the way guys, these are Bill's exact words in an email to me:

"The products are shipping to us on October 16. We should have them 7 to 10 days after that."
post #343 of 467
So by October 26 max. Sounds good, mine just cracked today due to cable exposure near the shell. This is my 2nd pair, the prior one had the same problem. I'm glad these issues are finally going to be dealt with.
post #344 of 467
Damn, after all this time it just happened... The cable close to the 3.5mm jack seems loose inside or malfunctioning. I get intermittent response from the left earpiece when the cable moves.

wbrownie, do I have to get in contact with you?
post #345 of 467
same here
New Posts  All Forums:Forum Nav: