New Posts  All Forums:Forum Nav:

Phonak Audeo Defect Thread - Page 8

post #106 of 467
Thread Starter 
Quote:
Originally Posted by buggalugs View Post
Thanks for your very helpful reply sooxieq.
You're welcome

Quote:
There is now a definite (but miniscule) crack on my LH earpiece - funny its now grown from about .5mm and only visible with a magnifying glass to about 1mm now and feelable (is that a word?) with a finger nail.
Tangible, but I know exactly what you mean by feelable

Quote:
This increase has occurred whilst it has been carefully stored in a drawer since my previous post about 6 hours ago - this would seem to indicate that the plastic housing is under a little stress even when not in use.
I'll carry on using the phones until and if the crack grows to a more obvious level.
You should really contact Swiss Hearing Aids and alert them to the fact you're going to need a replacement at some point. That will give them time to get new stock in (if they haven't already). And ask if they'd mind checking the date of manufacture before sending out a replacement. Never hurts to be organised

Meantime, I'll add you to the list...
post #107 of 467
Quote:
Originally Posted by soozieq View Post

mierenneuker - did your replacement come in new packaging, and if so, does it have a date of manufacture on the box?
They send me exact the same IEMs back, they only replaced the shell (I can tell because a slightly damage to the wire was still there)
didn't came with a new box, only the pouch
post #108 of 467
Thread Starter 
Quote:
Originally Posted by mierenneuker View Post
They send me exact the same IEMs back, they only replaced the shell
(I can tell because a slightly damage to the wire was still there)
didn't came with a new box, only the pouch
Hey, that's very odd. I thought damaged ones were being replaced with brand new models from new stock according to wbrownie. Try PM'ing him for more information. If your cable had started to show signs of damage too, then you seem to have been short changed if they've only replaced the shell, unless the cable damage was caused by something else. Either way, you should have got a totally new set, not just a shell replacement...

I'll add that to the list on the front page. But you should definitely PM wbrownie, he actually asked people to PM if there were any issues, so he won't mind
post #109 of 467
well, it is slightly dented, my fault :P
but I have PMed Bill, waiting for his reaction now
post #110 of 467
Wow......same here but a entirely different crack, plus my cord problems are BACK!!! I swear these are the best single armature phones I've ever heard. Excellent for all genres but these cord problems are nerve racking! Funny these is their customer service is so good. I'm willing to just send and receive a cord problem or crack comes on a defective unit These head phones rock!
post #111 of 467
Not clear. Replacement pair is defective too? My white ones are still intact, but I don't use them full-time (that's more for the Westone 3s). There is a slight bend in the white cable from "memory," but no damages I can see. I wonder how long this is gonna last (the cracking/cable issues). I hope Phonak is working on a replacement cable for the next gen PFEs.
post #112 of 467
[QUOTE=tstarn06;5615372]Not clear. Replacement pair is defective too? My white ones are still intact, but I don't use them full-time (that's more for the Westone 3s). There is a slight bend in the white cable from "memory," but no damages I can see. I wonder how long this is gonna last (the cracking/cable issues). I hope Phonak is working on a replacement cable for the next gen PFEs.[/QUOTE]


Agreed, I haven't been here in a while, I'm curious what's the main phone you use?
post #113 of 467
Ugh.. found out one of the phonaks I bought from Horen Mit Fiebing has hairline cracks too:





Time to msg Bill =(
post #114 of 467
[QUOTE=Confispect;5615405]
Quote:
Originally Posted by tstarn06 View Post
Not clear. Replacement pair is defective too? My white ones are still intact, but I don't use them full-time (that's more for the Westone 3s). There is a slight bend in the white cable from "memory," but no damages I can see. I wonder how long this is gonna last (the cracking/cable issues). I hope Phonak is working on a replacement cable for the next gen PFEs.[/QUOTE]


Agreed, I haven't been here in a while, I'm curious what's the main phone you use?
Answered on the other thread (re PFE tips). Westone 3, for most listening, especially on the go, best iso, no amp req. Also, I finally found a sleeve that works, no sibilance or mid-bass hump. They finally sound like $400 IEMs!
post #115 of 467
Quote:
Originally Posted by mierenneuker View Post
They send me exact the same IEMs back, they only replaced the shell (I can tell because a slightly damage to the wire was still there)
didn't came with a new box, only the pouch
That is very strange....

Some weeks ago Fiebing sent me a mail saying they will replace my PFEs.
Quote:"Please send us the defective headphones. You get a new headphone."
I've send mine for replacement yesterday.

I'll ask my money back if I don't get a new unit, I really hate to buy a brand new repaired product...and hope this isn't the case.
I must say I'm not happy with this very bad build quality product - Plastic cracks and stiff wire...only the drivers are worth the sound.
post #116 of 467
It didn't look like new because, the cable looks used, there is a stratch on the left side (the defect side), rubber on the left side was slightly damaged and there's more space between the two "things" (pic)

(not mine, too lazy to make a picture now)

so that makes me think they aren't new
and the cable was wrapped around itself, came with my used Comply tips
(have receiver free grey filters though)
post #117 of 467
Quote:
Originally Posted by mierenneuker View Post
It didn't look like new because, the cable looks used, there is a stratch on the left side (the defect side), rubber on the left side was slightly damaged and there's more space between the two "things" (pic)
....
so that makes me think they aren't new
and the cable was wrapped around itself, came with my used Comply tips
(have receiver free grey filters though)
If the cable was wrapped around itself (not like the original?) and if the box wasn't sealed (?) and with all other evidence, they are not new

Let's wait for Bill comment about this.

I was looking to other emails I changed with Fiebing and the said they would replace them...when I asked if the replacement was from a new batch...they replied:
QUOTE:"No, I do not know whether it is a different batch number. You get the headphones but from a different delivery."
post #118 of 467
Quote:
Originally Posted by tstarn06 View Post
Not clear. Replacement pair is defective too? My white ones are still intact, but I don't use them full-time (that's more for the Westone 3s). There is a slight bend in the white cable from "memory," but no damages I can see. I wonder how long this is gonna last (the cracking/cable issues). I hope Phonak is working on a replacement cable for the next gen PFEs.
According to Bill's reply to my PM a while back, they are working on new outer cable materials and a slightly longer cable for either future productions of the current PFE or the next IEM they come out with.
post #119 of 467
Quote:
I will check with the folks in Switzerland but to my knowledge parts are not available to fix them. They are to be replaced.
from Bill
post #120 of 467
Quote:
Originally Posted by gadgetman View Post
Ugh.. found out one of the phonaks I bought from Horen Mit Fiebing has hairline cracks too:
Time to msg Bill =(
... discovered some hairline cracks, a big one on the right side and a small one on the left side.
won't take long untill they become real cracks
New Posts  All Forums:Forum Nav: