Head-Fi.org › Forums › Equipment Forums › Computer Audio › Sound Blaster X-Fi Titanium: where are the Creative ASIO drivers?
New Posts  All Forums:Forum Nav:

Sound Blaster X-Fi Titanium: where are the Creative ASIO drivers?

post #1 of 5
Thread Starter 
Hi folks,

I have received an X-Fi Titanium as a gift...

I have installed it, and I upgraded the drivers from Creative's website to the latest version.

I have configured it in Audio Creation Mode to enable bitperfect playback, and connected it with the optical connection to my DAC.

My problem is that from Foobar2000 and Winamp, I only have the following options:

DS: SB X-Fi Audio
KS: SB X-Fi Audio
ASIO: ASIO4ALLv2

Shouldn't there also be a "Creative ASIO" option?

What am I missing? How can I enable the Creative ASIO drivers?

Thanks!
post #2 of 5
you need asio plugins for those apps, copy to directory then choose it in the application.
post #3 of 5
Thread Starter 
Yeah, thanks, pal... but I already have the ASIO plugins... As a matter of fact, I have been using Foobar/Winamp for a while with ASIO and ASIO4ALL.

My doubt comes from the fact that Creative cards are supposed to have their own ASIO drivers, so I wanted to try them instead of the generic ASIO4ALL ones...
post #4 of 5
I can adjust volume, bass & treble on the "mode switcher" does that mean ASIO isn't working?
post #5 of 5
Thread Starter 
Ok, I solved my problem...

It looks like the generic ASIO2KS plugin I had installed time ago on my system was messing up... I removed it, and now Creative ASIO drivers appear in the list and can be selected!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Sound Blaster X-Fi Titanium: where are the Creative ASIO drivers?