Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Phonak Audeo (PFE) Appreciation Thread
New Posts  All Forums:Forum Nav:

Phonak Audeo (PFE) Appreciation Thread - Page 12

post #166 of 2906
Quote:
Originally Posted by DeusInvictus7 View Post
Uh oh, you guys, I think I have a problem with my PFEs.

About an hour ago, I started noticing that my music has been feeling a little lop-sided. I took out both earpieces, and tried each by itself, and noticed that there was BARELY any sound coming out of the left piece, but the right was way louder and perfectly fine. Then I thought that it was my ear that was messed up, so I put the right piece in my left ear and it again, was perfectly fine...so now I have lop-sided earphones.

I did email Phonak Audeo about it, so I should hear back from them tomorrow. Hopefully I can get them replaced. Wish me luck.
How long have you had them? Was the cable yanked, or does there look like anything is wrong with the cable? Can you take the filters out and see if the sound comes back?
post #167 of 2906
Quote:
Originally Posted by average_joe View Post
How long have you had them? Was the cable yanked, or does there look like anything is wrong with the cable? Can you take the filters out and see if the sound comes back?
I've had them for...4 days. Cable was never yanked, and it looks like nothing is wrong with them.

OMG, I just took the filter out and put it back in, and it's fine now! Thanks for the suggestion, I don't know why I didn't even think about that!

Thanks again.
post #168 of 2906
Good thing that's all it was. You had potential buyers concerned . Lol.
post #169 of 2906
Quote:
Originally Posted by DeusInvictus7 View Post
I've had them for...4 days. Cable was never yanked, and it looks like nothing is wrong with them.

OMG, I just took the filter out and put it back in, and it's fine now! Thanks for the suggestion, I don't know why I didn't even think about that!

Thanks again.
Did you switch filters when you got them? Could the filter not have been in place properly, or did something get stuck between the filter and your ear canal?

Glad they are back to normal
post #170 of 2906
Quote:
Originally Posted by moseboy View Post
Good thing that's all it was. You had potential buyers concerned . Lol.
Haha! Yeah, I was so worried that something really happened.

Quote:
Originally Posted by average_joe View Post
Did you switch filters when you got them? Could the filter not have been in place properly, or did something get stuck between the filter and your ear canal?

Glad they are back to normal
Well I really don't know what was wrong with it. But yeah, I switched the grey filters with the black ones when I first got them because I liked the little boost in bass.

After I took it out and put it back in, it was fine for about 20 min or so, and then it started doing it again, so I put in the other pair of black filters, and everything seems to be fine now. I really hope the filters don't go out that quickly...that wouldn't be very practical.
post #171 of 2906
Quote:
Originally Posted by DeusInvictus7 View Post
Haha! Yeah, I was so worried that something really happened.



Well I really don't know what was wrong with it. But yeah, I switched the grey filters with the black ones when I first got them because I liked the little boost in bass.

After I took it out and put it back in, it was fine for about 20 min or so, and then it started doing it again, so I put in the other pair of black filters, and everything seems to be fine now. I really hope the filters don't go out that quickly...that wouldn't be very practical.
When I got them about 2 weeks ago I almost immediately switched to the black filters, used those for about 10 days with no problems, then switched to the grey filters. When I was switching, one of the black filters came off a little from the black ring. I guess the filters don't last forever, but they should last longer than 4 days
post #172 of 2906
I haven't read all those pages (I'm too lazy(to search for a webshop)) so can someone tell me on which (european) webshop those phonak audeos are the cheapest
post #173 of 2906
I have decided not to buy a PFE for now until they have established an "easier" means to sell to and support international customers (beside US and Canada).

I am convinced that the PFE is indeed a fine IEM. But everytime I plugged in my highly modded ER-4S, I was made to rethink my choice as I could not find any annoying fault in the way it is now.

So instead I am heading the Stax path....just gotta have that electrostatic sting on me ears
post #174 of 2906
Quote:
Originally Posted by dkcan View Post
Hmm I'm interested in getting these phones as well. I was originally thinking of UM1 but some head-fiers said its muddy and not worth the cost with exception of comfort.

Can anyone recommend a site I can order these from? Cheaper the better!
i had the UM1's..their on their way back to where they came from. i'm waiting for the PFE's to land probably tomorrow... here's hoping.
the UM1's were way too muddy/veiled etc for my liking.
post #175 of 2906
Quote:
Originally Posted by average_joe View Post
When I got them about 2 weeks ago I almost immediately switched to the black filters, used those for about 10 days with no problems, then switched to the grey filters. When I was switching, one of the black filters came off a little from the black ring. I guess the filters don't last forever, but they should last longer than 4 days
The filters should last a while, the problem is that they are extremely delicate and you should take your time when switching the filters with the filter tool. I think I twisted a little too much and the black filter ripped a little bit off of the ring.

Gentle, and patience!
post #176 of 2906
Quote:
Originally Posted by centerfold View Post
The filters should last a while, the problem is that they are extremely delicate and you should take your time when switching the filters with the filter tool. I think I twisted a little too much and the black filter ripped a little bit off of the ring.

Gentle, and patience!
The black filters are delicate. I have had that happen on both of mine. One I just pulled out of the case had the mesh end split from the cylinder.

The Grey ones that came installed with the PFE have had the same number of changes and are just fine. One of the black filters is completely trashed of the 3 left one is splitting at the mesh joint.
post #177 of 2906
Placed an order for the mic version last night and they shipped out today. Big difference over waiting for two months for my Livewires. I should have them by the end of the week and I'll post my opinions once I've had a chance to listen to them. Thanks to all on here for the reviews and recommendations!
post #178 of 2906
Phonak, or rather, their US distributor, emailed me this. Not for several months, but gives me something to save up for This was me asking them about multi-driver IEMs and customs

"Hi Eric,

I think that Phonak (HearingPlanet is the distributor in the US) has several products in the pipeline. Certainly the response they have received to this product has been very encouraging. I would not expect anything for several months however.

Best regards,
William H. Brownie"
post #179 of 2906
Thread Starter 
Hmmm.
post #180 of 2906
Imagine what would happen if Phonak created a Siren/BA dual driver IEM (so sort of like the SF5EB, but with a bass driver that can actually keep up). THAT would be interesting!
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Phonak Audeo (PFE) Appreciation Thread