Head-Fi.org › Forums › Equipment Forums › Computer Audio › GUIDE: Dolby Headphone in MPC & Zoom Player
New Posts  All Forums:Forum Nav:

GUIDE: Dolby Headphone in MPC & Zoom Player

post #1 of 51
Thread Starter 

If you already have Powerdvd installed and the options are gray just follow guide. You will however have TWO Cyberlink Audio Decoder filters, this should not cause any problems as Cyberlink installs its decoders in the common folder in program files. If you don't want two of the same decoders you can try and replace claud.sim located in C:\Program Files\Common Files\Cyberlink with an older version from the .rar I have uploaded. Don't know if this will break Powerdvd install, create a backup of claud.sim and try it! If it works skip the guide to setting up MPC or Zoom Player.

 

How to use Dolby Headphone in MPC Home Cinema or Zoom Player MAX.

1)Download and extract the .rar to your system32 folder. For 64bit users try the SYSWOW64 folder.

http://www.megaupload.com/?d=UYEIMJ50

 

2)Now its time to register the .ax. regsvr32 + the location of the .ax.
Start- Run: regsvr32 c:\windows\system32\claud.ax
d1a2ec106200933.jpg

2.1)If you ever decide you don't want this decoder installed use the -u switch then delete the 3 files.
Start- Run: regsvr32 -u c:\windows\system32\claud.ax

 

 

MPC Home Cinema
1) Open MPC and View-> Options. You can press the letter O to enter Options.
2) Internal Filters. Here you want to disable AC3/DTS Transform Filters.
3) Internal Filters-> External Filters. Add Filter...Look for Cyberlink Audio Decoder (PDVD10), select it and press ok. On the right, select Prefer.
4) Press Ok to exit the Options Menu. Playback a movie and check your Filter List.
5) Play-> Filters. Only ONE audio decoder should be in use, Cyberlink! If Cyberlink audio decoder is not being used or there is another decoder you need to go back to step 3). Find the other decoder in use, select it and press ok. On the right, select BLOCK. Playback a video and check your Filter List again. You may need to go back again and block more depending how many audio decoders you have installed.
6) Once complete you can then select Cyberlink Audio Decoder in the Filter List to choose Dolby Headphone. I prefer DH2, gives the right amount of space and voices sound natural.

4e91ff106200672.jpg 969cff106200674.jpg 93b7ec106200681.jpg 290bd9106201008.jpg

 

 

 

Zoom Player MAX
All older versions is the same. You will need to install the Gabest AC3/DTS XForm Filter.
http://www.inmatrix.com/zplayer/formats/dts.shtml

 

1) Open Zoom Player and go into Options. Pressing Ctrl+O will do this. Switch to Advanced Mode!

 

*You will need to enable Smart Play. I will not go into configuring video decoders and what not. I will assume you already have this enabled*

 

2) Playback-> Smart Play-> Audio Decoders. Select DTS Container and Configure.
3) Add Filter and Select AVI<->AC3/DTS. Add another filter, Cyberlink Audio Decoder (PDVD10). Cyberlink should be below the AVI<->AC3/DTS.
4) Select AC3 and configure. Follow step 3 but do NOT add the AVI<->AC3/DTS filter. Once done press ok to exit Config and Options Menu.
5) Playback a movie, right click the movie- Filter Properties: Here you can select Cyberlink Audio Decoder (PDVD10) and configure Dolby Headphone.
ff3520106201654.jpg 850cc5106201651.jpg bb5cc9106201657.jpg d88732106201656.jpg


Edited by MrKazador - 11/12/10 at 12:55pm
post #2 of 51
This was really useful, thanks!
post #3 of 51
Erm, I'm using the Nvidia audio decoder instead of cyberlink, and I'm having trouble getting it to work with DTS/AAC files. The Nvidia decoder just doesn't "pick up" FFDShow's LCPM output - so all I get is a lot of static noise when I use the LCPM output. Any tips here?
post #4 of 51
Thread Starter 
The nvidia decoder doesn't accept LPCM.

A while back ago I found out that Gabest MP4 Splitter fixes this bug so you don't need to use FFDSHOW anymore. The problem is with 24bit DTS audio, for some reason Haali doesn't like it.
post #5 of 51
could you please repost the screenshots as they seem to have disappeared
post #6 of 51
Thread Starter 
Not possible, seems like HDImage is down. I can help you with anything you don't understand.
post #7 of 51
Hey it's ok I got it working, I just wanted to see the screenshot with the settings for the custom matrix (L-L C-R R-C BL-LFE BR-BC LFE-SL).

Thanks again for the guide!
post #8 of 51
Thread Starter 
Instead of using the matrix, you can use Swap channels. A little easier to understand and works the same as matrix.
post #9 of 51
Want to thank MrKazador for this guide. Man I just can't get enough of this Dolby Headphone stuff. I think I need to tweak the sound a bit, but I'm really digging it.
post #10 of 51
I'm pretty happy now with both Dolby Headphone and DXVA enabled in MPC-HC.

That said, I noticed something strange:

- When playing an M2TS file with AC3, in the filters I see both Cyberlink and FFDSHOW
- When playing an MKV with DTS, same as above
- When playing an M2TS with DTS (remuxed from the mkv above), only Cyberlink is showing, and looking at the info, FFDSHOW doesn't intervene, so I'm not sure if its doing its channel remapping job or if it needs to (I don't have enough DTS sources to test yet, but the one movie I tried seems alright, and on the other hand, DD needs the remapping). If FFDSHOW is not used, then how does the LPCM get to the Cyberlink decoder directly?

Edit: I just realized that if FFDSHOW is not used at the same time as Cyberlink (as it is in the case of DD), then the channels bug doesn't exist and we don't need remapping...
post #11 of 51
Another thing I've noticed, sorry if it's well known: it seems better to disable the "Enable built-in audio switcher" option in the Audio Switcher config in MPC-HC, and that prevents having to run the sound through the MPC-HC audio switcher again after it comes out of the Cyberlink decoder. Instead, Cyberlink outputs it directly to the sound card. Seems like the MPC-HC audio switcher modifies something, at least the volume.
post #12 of 51
Quote:
Originally Posted by LeChucksBeard View Post
I'm pretty happy now with both Dolby Headphone and DXVA enabled in MPC-HC.

That said, I noticed something strange:

- When playing an M2TS file with AC3, in the filters I see both Cyberlink and FFDSHOW
- When playing an MKV with DTS, same as above
- When playing an M2TS with DTS (remuxed from the mkv above), only Cyberlink is showing, and looking at the info, FFDSHOW doesn't intervene, so I'm not sure if its doing its channel remapping job or if it needs to (I don't have enough DTS sources to test yet, but the one movie I tried seems alright, and on the other hand, DD needs the remapping). If FFDSHOW is not used, then how does the LPCM get to the Cyberlink decoder directly?

Edit: I just realized that if FFDSHOW is not used at the same time as Cyberlink (as it is in the case of DD), then the channels bug doesn't exist and we don't need remapping...
What is DXVA and how does it improve playback quality?
post #13 of 51
Thread Starter 
DXVA offloads the video onto the gpu which means, low cpu usage.
post #14 of 51
Does anyone know where I can download the cyberlink audio codec from? I'm having trouble finding it.
post #15 of 51
Is there any way to quickly switch from this set-up to a non-Dolby set-up?

Can you use Dolby Headphone with files that contain non-AC3 or DTS? ex. mp3, AAC,...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › GUIDE: Dolby Headphone in MPC & Zoom Player