Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › UE Super Fi 5 Pro earbuds are loose...
New Posts  All Forums:Forum Nav:

UE Super Fi 5 Pro earbuds are loose...

post #1 of 13
Thread Starter 
I've been using my super pro IEMs for 2 years now when I work (6 times a week) and the just now the wires' prongs seem to connect very loosely to the earbuds. The earbuds seem to disconnect themselves (slides off) from the wires very easily. Has anyone experienced this before? If so, is there a quick fix to this problem?
post #2 of 13
You might want to consider buying a new cable from UE (~$20) in order to diagnose if the problem lies with the cable or the IEM itself.
post #3 of 13
Thread Starter 
I did and it still slides off as easily as the old ones... Can't even jog without the earbuds falling out...
post #4 of 13
it may be worth purchasing a new cable, but if you have taken the cable off numerous times in those 2 years theres a possibility the actual connection on the earphones is worn and the cables are not holding.

this is because the cables are not actually designed to be constantly removed and upon doing so the components that hold the cable in place may have worn and gotten wider, there are cables with longer prongs but im not sure about thicker which you would require.

however you could email UE and see what they can do for you, because they are most likely out of warranty you may have to pay a small fee for a replacement set.

there is no real quick fix and if your lucky it may well just be the cable thats worn the prongs and the earphones may be fine, hence...this is why it may be worth purchasing a new cable, theres a 75% chance a new cable with new prongs will fit snug again, however the other 25% is a chance the connectors on the earphones are worn, if a new cable has the same problem you know its time to contact UE.

or contact them first anyway to see what they think.

hope this helps you, welcome to head fi and sorry about your wallet, prepare to lose some serious dosh if you stick around.
post #5 of 13
Thread Starter 
Quote:
Originally Posted by Taikero View Post
You might want to consider buying a new cable from UE (~$20) in order to diagnose if the problem lies with the cable or the IEM itself.
There is nothing really anything wrong with either the wires or the earbuds' prongs... It just seems the wires are "loosely" connected to the earbuds hence if I move too much, the earbud will actually detach itself from the wire.
post #6 of 13
Quote:
Originally Posted by ceekay84 View Post
There is nothing really with either the wires or the earbuds' prongs... It just seems the wires are "loosely" connected to the earbuds hence if I move too much, the earbud will actually detach itself from the wire.
if this is happening then theres clearly a problem with the cable or earphones connection.

do you remember how hard it was to disconnect the cable the first time you tried?? it should be that hard everytime, if it isnt then there is a problem with the connector which is most likely wearing of some kind.

if you want a real quick cheap fix just put a tiny bit of super glue on the bass of the connectors, trying not to cover the actual prongs and plug it into the earphones, hold for 20 seconds and there you go they wont fall out, its tacky and not advised so performing it is at your own risk and i take no responsibility, however it would work and the cable will certainly hold and if you needed to get it off it would just take a good pull to break the glue seal.
post #7 of 13
Thread Starter 
The left earbud seems intact and sits tight onto the prongs. The right one, however, sits quite loose. I wonder if UE will give me a new earbud piece???
post #8 of 13
Quote:
Originally Posted by ceekay84 View Post
The left earbud seems intact and sits tight onto the prongs. The right one, however, sits quite loose. I wonder if UE will give me a new earbud piece???
highly unlikely if you are out of warranty.
post #9 of 13
Thread Starter 
Here I was thinking it was Lifetime Warranty when I purchased the earbuds...
post #10 of 13
awww noooo lifetime warranty???? wouldnt we all love that.
post #11 of 13
How do you exactly work for such a thing to happen?
post #12 of 13
I'm not 100% positive, but iirc the westone es cable that many use to recable their superfi's have slightly larger prongs. Perhaps they may fit in your loose plugs? Maybe a head-fier who has recabled their superfi's with the westone cable can chime in on this.
post #13 of 13

It happened to me during warranty time.

I had a similar situatione happen. When I looked over the buds really carefully I could see a hairline crack. I was able to get a replacement pair from them, after they recieved mine and checked them over.

BTW thanks to HF I have UE SF 5 Pro, Meier Headsix, Senn 590 and passed on to my son. An Electric Ave PAV2 (?) and some sweet Grado's 225s for Christmas. What wallet!
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › UE Super Fi 5 Pro earbuds are loose...