Head-Fi.org › Forums › Misc.-Category Forums › DIY (Do-It-Yourself) Discussions › Problem with CF modded iPod Mini
New Posts  All Forums:Forum Nav:

Problem with CF modded iPod Mini

post #1 of 8
Thread Starter 
My CF modded iPod Mini was working fine up until the other day when rockbox acted weird a few times when using the file browser; the filenames were all garbage. When I hooked it up to a computer it was a bit messed up; my parents' Windows box would have nothing to do with it, didn't mount any volumes. My box, booted to Windows XP mounted it, but started having io trouble when using the volume.

Using Linux, dmesg showed me that it seemed fine, mounted, but later on gave me IO errors and problems with the file system.

I have restored it multiple times, both with iTunes (which partitioned it funny, the firmware partition didn't end on a cylinder according to fdisk), and manually with fdisk, dding the iPod firmware in and formatting the main partition to Fat32.

From this point, iPod firmware loaded and I could put music on it with iTunes, but when I reset it with Menu+Select it asks for the language selection again and doesn't save any preferences. I put rockbox 3 on it and the installation went fine but when I restarted the rockbox bootloader took ages and finally came up with a 'Partition not found' error.

I have checked and scanned the card (16gb PQI 120x CF) with HDTune and there are no bad blocks, it has an absolutely rock steady read/write speed, fast and uniform access times. The same thing also happens with different iPod Mini logic boards.

Any ideas on what could be wrong and how I can fix this?
post #2 of 8
Thread Starter 
Hmmm... seemed to have solved it by dding a firmware from another card that I had installed rockbox on. But I would still be interested in any insight into what the initial cause could have been.
post #3 of 8
I'll post this on both threads

I realize you found a solution, but I'll go ahead and post in case soemone else benefits.

Did you update the Mini's firmware before you swapped the drive for the CF card? I know people have had trouble with this mod and old Mini firmware.
post #4 of 8
Thread Starter 
The firmware was all up to date, luckily it was recent enough when I first got the mini as the HDD was dead. When putting in the CF with Apple firmware the iPod loaded the new firmware fine and started up, but then wouldn't save any settings. I haven't tried the Apple firmware after restoring last night with the firmware from the other card, I should see how that goes.
post #5 of 8
So you have 2 Minis with CF cards now?

I guess I'm not clear on how you solved the problem. My understanding is you already had a CF Mini that worked. You bought another, but it wouldn't work right, so you copied the first CF card to the new one, and then it worked.

Assuming I got that right, I can understand why that would work. I would probably still restore the Mini with the latest firmware form Apple. Even with Rockbox loaded, I think there is still some low level Apple code being used to initialize the hardware.

If it makes you feel any better, I've had a lot of problems along with way with mine. I have a total of 4 Minis now. Only one was supposed to be "fully functional", but it wasn't. I've had battery/charging issues. I have one now that has been working great for awhile. Since they were all sold "as is" not working. I can't be sure that the only problems with them were the hard drives or the batteries. I've been operating under that assumption since 90% of the time, that's what's wrong with them.

I'm planning to go back and work on the others some more, but I've lost a little enthusiasm for the project because of all the headaches. I need to do it though, so I can recoup some of the money I've spent. I plan to sell the other MiniMods (my name for them hehe) eventually. They are CF modded and DIYmod (ala iMod from Red Wine). I still need to make some LODs with decoupling caps first though. I also spent a lot of time trying to refinish the bodies. I ended up putting a vinyl skin on mine. :P
post #6 of 8
Thread Starter 
Yes, sorry for not being clear. I have more than one mini, one card (2gb) has RB on it from earlier, and I have another (16gb) which is the one that seems to be acting funny. The 16gb card was working ok with RB up until recently, when in started acting up I think was when I took it apart and put in a new higher capacity battery.

Apple firmware still won't save its settings (latest firmware) on the 16gb card with the firmware partition from the 2gb card, but RB seems to be working (which is the important bit). When I get home I'll check the 2gb card with this mini to make sure it's not a problem with the actual ipod.

Hopefully that made some sense. But it does seem like an odd issue.
post #7 of 8
I haven't looked very much into the software implications of the CF mods, but have you checked out darkfury's fix for the 3G? It's not entirely the same, I'm sure, but if you haven't read it already, it could be a clue to what you're looking for.
post #8 of 8
Thread Starter 
Thanks for the link, I'll have a read through tonight.
New Posts  All Forums:Forum Nav:
  Return Home
Head-Fi.org › Forums › Misc.-Category Forums › DIY (Do-It-Yourself) Discussions › Problem with CF modded iPod Mini