New Posts  All Forums:Forum Nav:

PX100 buzzing problem

post #1 of 5
Thread Starter 
My 4 year old PX100s recently started buzzing/rattling in the left ear. Certain notes trigger the buzz, and particularly lower-end notes. The sound seems fine otherwise – the buzz is just on top of the normal sound.

I've heard of this problem before, but couldn't find anything on Head-Fi about it. Does anyone have any insight? Is there a known fix?
post #2 of 5
is it a blown headphone maybe? is it a hum, hiss or more like a rattle?
post #3 of 5
Take off the pad and check for a hair on the diaphragm. I've read many times that this can cause buzzing.
post #4 of 5
Thread Starter 
Quote:
Originally Posted by scompton View Post
Take off the pad and check for a hair on the diaphragm. I've read many times that this can cause buzzing.
That was it! I had looked under the pad earlier but didn't notice that there were a few hairs there. I removed them with tweezers and now the buzzing seems to be gone.

Thanks so much. I was afraid I would have to buy a new pair.
post #5 of 5
Quote:
Originally Posted by Quinoa View Post
My 4 year old PX100s recently started buzzing/rattling in the left ear. Certain notes trigger the buzz, and particularly lower-end notes. The sound seems fine otherwise – the buzz is just on top of the normal sound.

I've heard of this problem before, but couldn't find anything on Head-Fi about it. Does anyone have any insight? Is there a known fix?
remove the foam over the headphone and check if on the driver there are hair (i found it on my px, especially if you have long hair !) or other things that does contact with the driver

Ciao!
New Posts  All Forums:Forum Nav: