Head-Fi.org › Forums › Equipment Forums › Computer Audio › Macbook audio out messed up?
New Posts  All Forums:Forum Nav:

Macbook audio out messed up?

post #1 of 8
Thread Starter 
Hey, my Macbook audio works fine when I hav e headphones in, but when I pull the plug out the audio does not come thru the speakers and the volume button shows a speaker with a slash thru it.

Also there is a red light in the plug port. Weird.
post #2 of 8
A Few thoughts:
First MB's have seperate volume for the internal speakers and anything using audio out. Aka if you have the headphone volume turned to 50% then take them out the speakers will return to the volume they were set to previously. So maby you have your speakers turned off, but your headphones have volume.

The red light is because the audio out doubles as a opticial line out, so the red light is on because the computer thinks that an optical cable is plugged in, which may be the other reason you get no sound out of the speakers.
post #3 of 8
Thread Starter 
Hmmmm, I'll have to go check the apple forums. I don't want to have to send it in! This happen to anyone else? More ideas?
post #4 of 8
There's a very useful Help manual embedded in the Mac OSX.
If you enter Sound Output in it, you'll be guided to numerous options.

Check System Preferences > Sound > Output. Have you chosen Internal Speakers. Are they muted?

Check your menu bar - the sound volume there (loudspeaker symbol) should show the same setting as in SysPrefs. But I have actually seen this at bottom, with the SysPref sound up on mine.

Next. Applications > Utilities > Audio MIDI Setup.
Check that you haven't chosen some weird setup there.
post #5 of 8
Thread Starter 
I checked the Apple forums and It seems a lot of people are having this same issue. Guess it has to be sent in..... Crap.
post #6 of 8
Quote:
Originally Posted by dozens View Post

Also there is a red light in the plug port. Weird.
The minijack OUT port doubles for both analog minijack and for optical digital OUT. The red light is the optical signal. But on my Macs that only begins when I have a Toslink Optical minijack connected.

Check your output configuration again - seems you have set it to pipe optica, digital.
Do you have an y soundcards attached? If so, then the OS may have read that you want to output digital. That happens automatically with my computer when I connect my TosLink minijack to it.
post #7 of 8
Thread Starter 
So yeah, it's something wrong with the port - gotta mail it in. ******.
post #8 of 8

When it goes to output digital does that override the Mac Dac?
Quote:

Originally Posted by Soundproof View Post   ..the OS may have read that you want to output digital. That happens automatically with my computer when I connect my TosLink minijack to it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Macbook audio out messed up?