Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › The Extreme has arrived!
New Posts  All Forums:Forum Nav:

The Extreme has arrived! - Page 29

post #421 of 428
I received my Singlepower Extreme today. Among the tubes I received there are two Sylvania 6080, and a 2C51 with adapter I will try first. It came with an supplementary power supply. This I connect to the Singlepower extreme. I have just received one power cable. But there is a power cable outlet in both the Extreme and the supplementary power supply. I guess I have to put a power cable in each of them, or am I wrong?
post #422 of 428
Thread Starter 
Quote:
Originally Posted by arirug View Post
I received my Singlepower Extreme today. Among the tubes I received there are two Sylvania 6080, and a 2C51 with adapter I will try first. It came with an supplementary power supply. This I connect to the Singlepower extreme. I have just received one power cable. But there is a power cable outlet in both the Extreme and the supplementary power supply. I guess I have to put a power cable in each of them, or am I wrong?
Yes, each section needs a power cord.

This would be an Extreme Platinum?

Is there any chance the cable you received is the umbilical to connect the amp section and the power supply? The amp section and outboard power supply should have a connection.
post #423 of 428
Yes, I got two cables, one umbilical to connect the amp section and the power supply, and one power cord. I ordered a Singlepower Extreme, but do you think I received an Extreme Platinum? Thanks for answering my question so fast!
post #424 of 428
Thread Starter 
Quote:
Originally Posted by arirug View Post
Yes, I got two cables, one umbilical to connect the amp section and the power supply, and one power cord. I ordered a Singlepower Extreme, but do you think I received an Extreme Platinum? Thanks for answering my question so fast!
Not necessarily. Are you outside of the US? All the International Extremes use an outboard power supply. Why? I dont think he can fit the 220 volt transformer he uses in one box because the transformer is to large.

Edit: I was typing when I thought of this and I see you are outside the USA so that is the reason why.
post #425 of 428
Yes, I live in Norway 220-240V enviroment. Thank you for telling me this! But do I still need to use two power cords, or is it enough putting it in the extra power supply?
post #426 of 428
Thread Starter 
Before you ask, in this design the outboard power supply contains the high voltage B+. The amp section has the transformer that powers the heater filaments of the tubes. I like to turn on the heater supply before I hit the amp with the high voltage B+ side. When you turn on the amp section you will see the tubes glow for the heaters. When you turn on the outboard power supply you wont hear anything.

Make sure you have tubes in the amp before you turn on anything.
post #427 of 428
Thread Starter 
Quote:
Originally Posted by arirug View Post
Yes, I live in Norway 220-240V enviroment. Thank you for telling me this! But do I still need to use two power cords, or is it enough putting it in the extra power supply?

You need power cords in both .... read my previous post for an explanation of what each section does. Keep asking if you need more help.

Edit: I have to go to the post office. If you have anymore questions I will answer them when I get back
post #428 of 428
Thank you, I really appreciate your help!! I have allready put in the tubes. Two Sylvania 6080 and an 2C51 on adapter in the front It was very good information you gave me here!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › The Extreme has arrived!