Head-Fi.org › Forums › Equipment Forums › Computer Audio › Problem with DTS encoded music files
New Posts  All Forums:Forum Nav:

Problem with DTS encoded music files

post #1 of 24
Thread Starter 
My setup can play DTS encoded music and movies from my harddrive if they are in the DVD VOB format. However, if I try to play DTS encoded WAV or CDA files, my Sony receiver recognizes the DTS signal but the sound is garbled. I have tried two different soundcards digital out with no success. I have tried WMP and MyDVD also both with the same problem.

Any ideas?

Thanks in advance.

J
post #2 of 24
What is your OS and sound card?

I assume your volume control is at 100% when you try this?

Cheers

Thomas
post #3 of 24
Looks like both of the soundcards tried did not support 44.1 kHz natively, which is required for DTS CD playback. With a card that does, be sure to turn on non-audio mode if required.
post #4 of 24
Turning on non audio mode is not required for DTS encoded WAV. The whole idea is that this data travels in-band a standard 16bit/44.1Khz data stream.

What you need to make sure is that you get the bits out the digital interface unmodified.

Cheers

Thomas
post #5 of 24
Thread Starter 
Quote:
Originally Posted by thomaspf
What is your OS and sound card?

I assume your volume control is at 100% when you try this?

Cheers

Thomas
I am running XP SP2 in a Dell Dimension 8300 3.0 GHz with SATA 10k HD. I have tried two cards:

1) Audigy MP3 Audition, latest drivers, mini out to RCA digital in
2) M-Audio Audiophile 2496, latest drivers, RCA out to RCA digital in

The closest I can get is using WinDVD SPDIF output, the receiver recpognizes the 3/2 DTS signal but the sound is garbled but I can still make out the music it just sounds like it is put through a super fast vibrato effect.
post #6 of 24
I had the same problem with my onkyo with DTS, I ended up figuring out that my onkyo had to be put in DTS mode instead of PCM which it was in. The setting is not even mentioned in the manual.

Maybe this will help?
post #7 of 24
The Audigy definately will not work. It resamples everything to 48kHz which is what is creating your funky sound.

I'm pretty sure the M-Audio will work, but you may have to dink with the drivers for a while to get them working correctly. Double check and make sure both the player and sound card driver are set to DD/DTS pass through.
post #8 of 24
The M-audio should work when you play the WAV tracks in bit perfect mode.

Get yourself a player that supports ASIO like Foobar with the ASIO plugin or JRMC configured for ASIO and you should be ready to go.

I am using an M-audio DIO24/96 and these discs or ripped wavs play just fine in standard consumer mode.

Cheers

Thomas
post #9 of 24
Try it with foobar with kernel streaming or asio. I had that problem when I tried playing it through itunes and powerdvd. It would pick up the dts signal from itunes but would only output static and powerdvd worked with spdif when in disc mode but was disabled when playing wav files.
post #10 of 24
Is the 2496 hardware-mixing capable? If so, you should be able to output bit-perfect results through DirectSound by enabling the setting in the driver.
post #11 of 24
The 2496 is a Via Envy based card with a custom driver. Where would you enable such feature if it is not already reported when the driver initializes?

Cheers


Thomas
post #12 of 24
Thread Starter 
Quote:
Originally Posted by thomaspf
The M-audio should work when you play the WAV tracks in bit perfect mode.

Get yourself a player that supports ASIO like Foobar with the ASIO plugin or JRMC configured for ASIO and you should be ready to go.

I am using an M-audio DIO24/96 and these discs or ripped wavs play just fine in standard consumer mode.

Cheers

Thomas
I got Foobar and can not get any output in Kernel Streaming mode and for ASIO (M-Audio) I get the following error with DTS WAV (I can not even play normal MP3s which get the same error).

INFO (foo_output_asio(dll)) : open : 44100 Hz, LINEAR PCM, 16 bits, 2 channels
INFO (foo_output_asio(dll)) : ASIO device type [channel 0] : Int32LSB
INFO (foo_output_asio(dll)) : ASIO device type [channel 1] : Int32LSB
ERROR (foo_output_asio(dll)) : unsupported output data format.

Any ideas?

Thanks. J
post #13 of 24
Thread Starter 
Quote:
Originally Posted by Blitzzz
Try it with foobar with kernel streaming or asio. I had that problem when I tried playing it through itunes and powerdvd. It would pick up the dts signal from itunes but would only output static and powerdvd worked with spdif when in disc mode but was disabled when playing wav files.
Yes this is my situation, I can play with PowerDVD in disc mode when it is a DVD (VOB format), cda and .wav DISC I get garbled noise. I did notice that in this mode my M-Audio is locked at 48kHz but does not allow me to change it. Should it be in 44.1 or 48kHz mode?
post #14 of 24
Definitely 44.1 kHz for DTS CDs. As for why Foobar won't work with ASIO, no idea. Winamp seems to be less finicky there. You do have the latest drivers for the AP2496, right?
post #15 of 24
Yes winamp or JRMC are less finicky since they automatically adapt from whatever internal format you select to the capabilities of the sound card.


This is not true for foobar. The ASIO driver for the M-audio card does only support int32 and you need to select either fixed point 32 bits or fixed point 24 bits padded to 32 as the ouput format in foobar to make this work.
ASIOcaps from the same author as the plugin lets you see all the supported formats.

You also need to disable any resampling, DSP processing, replaygain and volume control.

You are almost there!

Cheers

Thomas
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Problem with DTS encoded music files