Solid iPod Release

A Review On: Apple iPod classic 120 GB Black (6th Generation) [Previous Model]

Apple iPod classic 120 GB Black (6th Generation) [Previous Model]

See all 1 reviews
Recent Pricing:
Review Details:
Audio Quality
Battery Life
Design
User Interface
Value
Purchased on:
Price paid: $130.00
JoeDoe
Posted · 543 Views · 1 Comment

Pros: Size, Construction, Features, Capacity, UI

Cons: Non-Rockbox-able, prone to scratches, HD can be laggy

Even though I'm pretty sure everyone gets the gist on these, I'll drop a few words anyway.

 

I purchased a gently used model of the 120gb 6th generation over the 80gb 5th or 6th generation for a few reasons:

 

1. For most iPod-ready headphones, the 6th generation (and newer) 120 and 160gb are those that are compatible. On two separate occasions, I was told by manufacturers that the 80 gb from the first 6th generation run would not work with my iDevice inline controls. 

 

2. Battery life. The only iPod ever to claim a better battery life than this one is the 160 from the 6.0 generation (this could be considered 6.1).

 

3. Space. I will never need more space than this. 160 is just too much. Yes my library is slightly larger than 120gb and growing, however, I don't need all of my music with me all the time. It's not like I'll listen to all of it!

 

4. UI. Like this needs explaining. I've never seen an interface as easy to understand and navigate at this. Not to mention this gen. has Genius and VoiceOver. Touch screens are nice, but they eat up battery and cannot be navigated without looking. Guess who can? Classic!

 

I've read several posts about how the 5.5 gen iPod sounds better with its Wolfson chip and whatnot. I can't tell. I did a side by side with identical headphones and songs and couldn't hear a difference. This is a portable music device designed for compressed audio files. Period. The cans will make the biggest difference anyway!

 

All in all, I certainly recommend. 

1 Comment:

i was able to get a rockbox version to work on my 6th gen. sadly it doesnt work with windows 8 so you have to have windows seven for some reason