New Posts  All Forums:

Posts by augustwest

Thanks all, it looks like I will be getting my SP MPX3 fixed instead getting something different.
Thanks,   "Kevin Gilmore has posted it a few times.    http://www.head-fi.org/t/436281/supra-schematic   Same as a supra, with some part value differences in the audio section, and LARGE differences in the power supply section.  Since every SP is just a little bit speshul, the best you will find is really just a guideline. That should get anyone who should be poking around in there started anyways.    The "gain control" was just a few extra resistors in the volume...
Schematic for SinglePower MPX3?   Does anyone have basic schematic for a SinglePower MPX3? My MPX3 had the usual transformer failure last week. I currently have a amp tech who will replace the it with a more robust one.   While he has it apart, I asked that he install a “gain reduction” toggle switch to occupy the hole that was previously used for the “high power” switch that is being removed. To make this request easier, he ask if I could come up with a basic...
Schematic for SinglePower MPX3?   Does anyone have basic schematic for a SinglePower MPX3? My MPX3 had the usual transformer failure last week. I currently have a amp tech who will replace the it with a more robust one.   While he has it apart, I asked that he install a “gain reduction” toggle switch to occupy the hole that was previously used for the “high power” switch that is being removed. To make this request easier, he ask if I could come up with a basic...
"Sh**. I hope you can get it sorted. Did you try replacement tubes?"     "My darkvoice did that once... It was just the fuse that popped. Not sure what caused it"     I check the fuse and it was burnt. Replaced the fuse and it immediately burnt again. The amp is currently with someone who repairs guitar amps and builds the custom Red Jones Amps. If you play electric guitar, or just appreciate fine craftsmanship you might want to check these amps out...
My MPX3 was working fine until last week when it stopped working. No drama, no loud pop, no burning smell, no smoke, it just stopped and went cold mid-CD. I'm now trying to learn what is wrong with it and if it will be repair, or replace.
"I guess your choice also depends on which headphone you want to use."   Well that is part of the dilemma I use Grados, HD650s & Beyer DT990s. However, I use the HD650s / DT990s most. That said I do need something that will work with the Grados too.   Another question in my mind, of the two amps under consideration (LD MK111 / DV336) which has the most bass impact (amount and quality of)? Any thoughts there? 
Masa -   I was listening to it a couple of nights ago and it just stopped. It went "stone dead", nothing dramatic; no loud pop, or puff of smoke, or burning smell, it just stopped. So now it is fix, or replace.
Masa -   I have found a place in Venice who says they will take a look, "Venice Amp Repair", they specialize in the custom "Red Jones" guitar amps. I will give "Rewind Audio" a try if if that doesn't work out. How is your SP amp holding up, or do you still have it?
Bummer.   BTW, I think I learned about washing / soaking Grado cushions from one of your old posts. Much smoother and softer. Thank you.     I haven't been on < headfi > much recently. Have been enjoying the music, and content with my system, until my SP MXP3 quit on me last week. Thank you for the kind words.
New Posts  All Forums: