New Posts  All Forums:

Posts by Lex Tan

Thanks amictus, well I also hope that I can fix the problem on my own as well.
Well I think It should most likely to be a batch problem and I could easily said that I just got the problem batch, pure unlucky and I really think there is no reason for me to exchange for a new set as it is quite clear that history will repeat itself. I think as of now I should exchange for a non usb set and hopefully it will be fine... Finger cross!
Well I did exchange email with Norbert and his reply is kind of slow so I went ahead to exchange for the amp. Guess what, even the replacement amp is having the exact same problem. Now I'm really in doubt of the quality of their amp, 2 amps with the same exact problem, how could that even be possible.
Hi, does you lehmann BCL at gain setting +10 dB experienced hissing sound when turn your volume knob to one o'clock position?
I'm a new owner of Lehmann BCL and a something peculiar with this amp. When I configure the gain switch to very loud +20 DB, and when I turned the volume knob to 12 o'clock with HD800 hooked up. I hear a hissing noise. Is this a norm? Anyone?
I'm a new owner of Lehmann BCL and a something peculiar with this amp. When I configure the gain switch to very loud +20 DB, and when I turned the volume knob to 12 o'clock with HD800 hooked up. I hear a hissing noise. Is this a norm? Anyone?
I'm a new owner of Lehmann BCL and a something peculiar with this amp. When I configure the gain switch to very loud +20 DB, and when I turned the volume knob to 12 o'clock with HD800 hooked up. I hear a hissing noise. Is this a norm? Anyone?
I'm a new owner of Lehmann BCL and a something peculiar with this amp. When I configure the gain switch to very loud +20 DB, and when I turned the volume knob to 12 o'clock with HD800 hooked up. I hear a hissing noise. Is this a norm? Anyone?
I'm a new owner of Lehmann BCL and a something peculiar with this amp. When I configure the gain switch to very loud +20 DB, and when I turned the volume knob to 12 o'clock with HD800 hooked up. I hear a hissing noise. Is this a norm? Anyone?
My genuine pleasure, glad that my input helps!
New Posts  All Forums: